Bug 1030673 - Error: Method "Connect" with signature "s" on interface "org.bluez.Serial" doesn't exist
Error: Method "Connect" with signature "s" on interface "org.bluez.Serial" do...
Status: CLOSED DUPLICATE of bug 1055628
Product: Fedora
Classification: Fedora
Component: network-manager-applet (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 17:22 EST by Jakub Dorňák
Modified: 2016-11-30 19:57 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-16 13:05:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (35.67 KB, image/png)
2013-11-14 17:22 EST, Jakub Dorňák
no flags Details

  None (edit)
Description Jakub Dorňák 2013-11-14 17:22:31 EST
Created attachment 824172 [details]
screenshot

Description of problem:
Can not set my phone device to be used for internet connection:

Version-Release number of selected component (if applicable):
gnome-bluetooth-3.10.0-1.fc20.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. run gnome-control-center
2. select bluetooth
3. connect to the phone device
4. try to select "Access the Internet using your mobile phone (DUN)" checkbox

Actual results:

The checkbox gets immediately unchecked and an error message appears (see Subject).

Screenshot attached, the output from terminal follows:

[jdornak@colt ~]$ LC_ALL=C gnome-control-center 
** Message: has_config_widget D4:C1:FC:77:04:0F SyncMLClient
** Message: has_config_widget D4:C1:FC:77:04:0F SerialPort
** Message: has_config_widget D4:C1:FC:77:04:0F DialupNetworking
** Message: has_config_widget D4:C1:FC:77:04:0F OBEXObjectPush
** Message: has_config_widget D4:C1:FC:77:04:0F OBEXFileTransfer
** Message: has_config_widget D4:C1:FC:77:04:0F AudioSource
** Message: has_config_widget D4:C1:FC:77:04:0F A/V_RemoteControlTarget
** Message: has_config_widget D4:C1:FC:77:04:0F A/V_RemoteControl
** Message: has_config_widget D4:C1:FC:77:04:0F Headset_-_AG
** Message: has_config_widget D4:C1:FC:77:04:0F HandsfreeAudioGateway
** Message: has_config_widget D4:C1:FC:77:04:0F SIM_Access
** Message: has_config_widget D4:C1:FC:77:04:0F Phonebook_Access_-_PSE
** Message: has_config_widget D4:C1:FC:77:04:0F SyncMLClient
** Message: has_config_widget D4:C1:FC:77:04:0F SerialPort
** Message: has_config_widget D4:C1:FC:77:04:0F DialupNetworking
** Message: has_config_widget D4:C1:FC:77:04:0F OBEXObjectPush
** Message: has_config_widget D4:C1:FC:77:04:0F OBEXFileTransfer
** Message: has_config_widget D4:C1:FC:77:04:0F AudioSource
** Message: has_config_widget D4:C1:FC:77:04:0F A/V_RemoteControlTarget
** Message: has_config_widget D4:C1:FC:77:04:0F A/V_RemoteControl
** Message: has_config_widget D4:C1:FC:77:04:0F Headset_-_AG
** Message: has_config_widget D4:C1:FC:77:04:0F HandsfreeAudioGateway
** Message: has_config_widget D4:C1:FC:77:04:0F SIM_Access
** Message: has_config_widget D4:C1:FC:77:04:0F Phonebook_Access_-_PSE
** Message: Default Bluetooth adapter is powered
** Message: dun_start: starting DUN device discovery...
** Message: Detecting phone configuration...
** Message: dun_start: calling Connect...
** Message: dun_start: waiting for Connect success...
** Message: dun_connect_cb: processing Connect reply

** (gnome-control-center:12685): WARNING **: dun_connect_cb: DUN error: Method "Connect" with signature "s" on interface "org.bluez.Serial" doesn't exist

** Message: Error: Method "Connect" with signature "s" on interface "org.bluez.Serial" doesn't exist

** Message: dun_connect_cb: finished
Comment 1 Bastien Nocera 2013-11-14 18:47:49 EST
The plugin is provided by network-manager-applet.
Comment 2 Stanislav Hanzhin 2013-12-07 09:33:30 EST
Same thing for me with two different phones
Comment 3 Dario Lesca 2013-12-12 18:20:09 EST
(In reply to Stanislav Hanzhin from comment #2)
> Same thing for me with two different phones
Idem
bluez-5.11-1.fc20.x86_64
network-manager-applet-0.9.9.0-7.git20131028.fc20.x86_64
Comment 4 Kamil Stawirej 2014-01-01 08:22:54 EST
Same here unfortunately.

network-manager-applet-0.9.9.0-7.git20131028.fc20.x86_64
bluez-5.12-2.fc20.x86_64

Let me add that this bug is very annoying. It renders bluetooth useless.
Comment 5 James Harrion 2014-07-12 02:49:02 EDT
Save problem here on bifferent Blackberry phones. Bluetooth on F20 is useless for me.


Using:
bluez-5.18-1.fc20.x86_64
NetworkManager-0.9.9.0-41.git20131003.fc20.x86_64
Comment 6 Dan Williams 2014-07-16 13:05:28 EDT

*** This bug has been marked as a duplicate of bug 1055628 ***

Note You need to log in before you can comment on or make changes to this bug.