Bug 1030732 - CopyTrans fails when invoked by pushing source document from client
CopyTrans fails when invoked by pushing source document from client
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-CopyTrans (Show other bugs)
development
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2
Assigned To: Carlos Munoz
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 22:15 EST by Sean Flanigan
Modified: 2014-02-18 01:48 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2-SNAPSHOT (20131118-1242)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 01:48:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
partial server.log (10.83 KB, text/plain)
2013-11-14 22:15 EST, Sean Flanigan
no flags Details

  None (edit)
Description Sean Flanigan 2013-11-14 22:15:22 EST
Created attachment 824271 [details]
partial server.log

Description of problem:
CopyTrans fails when invoked by pushing document from client

Version-Release number of selected component (if applicable):
Zanata version 3.2-SNAPSHOT (20131114-1743)

How reproducible:
Pretty consistent, I think.

Steps to Reproduce:
1. Use zanata-cli to push a document, with copytrans enabled

Actual results:

Client log:
[INFO] pushing source doc [name=authconfig size=251] to server
Done in 0 secs
[INFO] Running Copy Trans for authconfig
Done in 0 secs
[WARN] Copy Trans for the above document stopped unexpectedly.

Server log: see attachment

Expected results:
CopyTrans successful, no error logged

Additional info:
Comment 1 Carlos Munoz 2013-11-15 00:53:53 EST
I think this is caused by new changes in the uses of 'Activity ' when pushing source documents. Copy trans from the UI doesn't seem to be affected, but it's worth testing it too.

All hibernate entities that are used inside Work implementations should be loaded from inside the work invocation. Similarly, and we are more conscious of this, any Seam component instance used inside an AsyncTask implementation should be loaded from within the async call and not passed in.

See:
https://github.com/zanata/zanata-server/pull/274
Comment 2 Carlos Munoz 2013-11-15 01:35:51 EST
See instead:
https://github.com/zanata/zanata-server/pull/275
Comment 3 Ding-Yi Chen 2013-11-17 23:19:01 EST
VERIFIED with Zanata version 3.2-SNAPSHOT (20131118-1242)
zanata-maven-plugin:3.1.2

Note You need to log in before you can comment on or make changes to this bug.