Bug 1030747 - /etc/init.d/vncserver fails if user's shell is csh
/etc/init.d/vncserver fails if user's shell is csh
Status: CLOSED DUPLICATE of bug 949522
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tigervnc (Show other bugs)
6.4
All Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 23:16 EST by John Hein
Modified: 2013-11-18 07:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 07:34:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
let vncserver fail if there is a missing passwd file (606 bytes, text/plain)
2013-11-14 23:22 EST, John Hein
no flags Details

  None (edit)
Description John Hein 2013-11-14 23:16:13 EST
Description of problem:

/etc/init.d/vncserver calls runuser with a command that fails when the user's shell is csh (because of syntax:  if [ -r .vnc/passwd ]; then ... fi).

Version-Release number of selected component (if applicable):

tigervnc-server-1.1.0-5.el6_4.1.i686


How reproducible:

Always.

Steps to Reproduce:
1.  Put entries in /etc/sysconfig/vncservers, such as:

VNCSERVERS="1:userjoe"
VNCSERVERARGS[1]="-geometry 1280x768 -depth 16"

2.  Make 'userjoe' have /bin/csh as shell


3.  start vncserver service:

sudo service vncserver start



Actual results:

Starting VNC server: 1:userjoe Invalid null command.
if: Expression Syntax.

Expected results:

Starting VNC server: 1:userjoe                             [  OK  ]

Additional info:

Just adding -s /bin/sh to the runuser call lets the runuser command complete successfully, but then SHELL is set incorrectly in the vnc session's environment.
Comment 1 John Hein 2013-11-14 23:22:56 EST
Created attachment 824289 [details]
let vncserver fail if there is a missing passwd file

Just run vncserver and let vncserver fail if there is a missing passwd file.
Comment 3 Tim Waugh 2013-11-18 07:34:41 EST

*** This bug has been marked as a duplicate of bug 949522 ***

Note You need to log in before you can comment on or make changes to this bug.