Bug 1030801 - [abrt] pkgwat-0.9-1.fc20: pkg_resources.py:576:resolve:DistributionNotFound: pyparsing<=1.5.7
[abrt] pkgwat-0.9-1.fc20: pkg_resources.py:576:resolve:DistributionNotFound: ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pkgwat (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralph Bean
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:c937ac5de8c69d8ac07483906b7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 02:28 EST by Parag Nemade
Modified: 2013-11-15 13:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 13:42:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.77 KB, text/plain)
2013-11-15 02:28 EST, Parag Nemade
no flags Details
File: environ (3.61 KB, text/plain)
2013-11-15 02:28 EST, Parag Nemade
no flags Details

  None (edit)
Description Parag Nemade 2013-11-15 02:28:09 EST
Description of problem:
install pkgwat
use command on terminal as "pkgwat"

Version-Release number of selected component:
pkgwat-0.9-1.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python2 /usr/bin/pkgwat
dso_list:       python-setuptools-1.3.1-1.fc20.noarch
executable:     /usr/bin/pkgwat
kernel:         3.11.7-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
pkg_resources.py:576:resolve:DistributionNotFound: pyparsing<=1.5.7

Traceback (most recent call last):
  File "/usr/bin/pkgwat", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2797, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 576, in resolve
    raise DistributionNotFound(req)
DistributionNotFound: pyparsing<=1.5.7

Local variables in innermost frame:
dist: None
to_activate: [pkgwat.cli 0.9 (/usr/lib/python2.7/site-packages), fabulous 0.1.5 (/usr/lib/python2.7/site-packages), cliff 1.4.4 (/usr/lib/python2.7/site-packages), six 1.4.1 (/usr/lib/python2.7/site-packages), pkgwat.api 0.10 (/usr/lib/python2.7/site-packages), grapefruit 0.1a3 (/usr/lib/python2.7/site-packages)]
req: Requirement.parse('pyparsing<=1.5.7')
requirements: [Requirement.parse('cmd2>=0.6.4,<0.6.6'), Requirement.parse('PrettyTable>=0.6,<0.8'), Requirement.parse('requests'), Requirement.parse('six')]
processed: {Requirement.parse('cliff'): True, Requirement.parse('six'): True, Requirement.parse('grapefruit'): True, Requirement.parse('fabulous'): True, Requirement.parse('pkgwat.api>=0.9'): True, Requirement.parse('pkgwat.cli==0.9'): True}
env: <pkg_resources.Environment object at 0x16a11d0>
installer: None
self: <pkg_resources.WorkingSet object at 0x16a1390>
best: {'pkgwat.cli': pkgwat.cli 0.9 (/usr/lib/python2.7/site-packages), 'fabulous': fabulous 0.1.5 (/usr/lib/python2.7/site-packages), 'pkgwat.api': pkgwat.api 0.10 (/usr/lib/python2.7/site-packages), 'six': six 1.4.1 (/usr/lib/python2.7/site-packages), 'grapefruit': grapefruit 0.1a3 (/usr/lib/python2.7/site-packages), 'pyparsing': None, 'cliff': cliff 1.4.4 (/usr/lib/python2.7/site-packages)}
Comment 1 Parag Nemade 2013-11-15 02:28:16 EST
Created attachment 824347 [details]
File: backtrace
Comment 2 Parag Nemade 2013-11-15 02:28:19 EST
Created attachment 824348 [details]
File: environ
Comment 3 Ralph Bean 2013-11-15 13:42:06 EST
The issue is that python-pyparsing has been updated on your system but python-cliff has not.  If you update python-cliff it should end up working.

Note You need to log in before you can comment on or make changes to this bug.