Bug 1030892 - Failed to git push after successfully installed Mail in php app.
Failed to git push after successfully installed Mail in php app.
Status: CLOSED DUPLICATE of bug 1000223
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 05:31 EST by Liang Xia
Modified: 2015-05-14 20:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 11:10:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
StepsAndResults of bug1030892 (23.60 KB, text/plain)
2013-11-15 05:33 EST, Liang Xia
no flags Details

  None (edit)
Description Liang Xia 2013-11-15 05:31:41 EST
Description of problem:
After successfully installed Mail in php app ( via adding Mail in deplist.txt and git push),
made another change and git push, will met:
remote: Building PHP cartridge
remote: Checking pear: Mail
remote: 
remote: PHP Notice:  unserialize(): Error at offset 7700 of 12711 bytes in /usr/share/pear/PEAR/Registry.php on line 1145
remote: PHP Stack trace:
remote: PHP   1. {main}() /usr/share/pear/pearcmd.php:0
remote: PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
remote: PHP   3. PEAR_Command_Registry->doList() /usr/share/pear/PEAR/Command/Common.php:271
remote: PHP   4. PEAR_Command_Registry->doFileList() /usr/share/pear/PEAR/Command/Registry.php:146
remote: PHP   5. PEAR_Registry->getPackage() /usr/share/pear/PEAR/Command/Registry.php:278
remote: PHP   6. PEAR_Registry->_getPackage() /usr/share/pear/PEAR/Registry.php:1962
remote: PHP   7. PEAR_Registry->_packageInfo() /usr/share/pear/PEAR/Registry.php:1443
remote: PHP   8. unserialize() /usr/share/pear/PEAR/Registry.php:1145
remote: PHP Warning:  Invalid argument supplied for foreach() in /usr/share/pear/PEAR/Command/Registry.php on line 304
......

Version-Release number of selected component (if applicable):
devenv_4038
rhc 1.17.5

How reproducible:
always

Steps to Reproduce:
1.Create an php app.
2.Git clone the repo to local.
3.Add Mail in deplist.txt and git push the change.
4.Made another change and git push.

Actual results:
Step 4 failed with error as in description.

Expected results:
Git push successfully.

Additional info:
Comment 1 Liang Xia 2013-11-15 05:33:11 EST
Created attachment 824441 [details]
StepsAndResults of bug1030892
Comment 2 Andy Goldstein 2013-11-18 10:02:43 EST
This appears to be a duplicate of bug 1000223
Comment 3 Andy Goldstein 2013-11-18 11:10:28 EST

*** This bug has been marked as a duplicate of bug 1000223 ***

Note You need to log in before you can comment on or make changes to this bug.