Bug 1030944 - package pulls python3 dependency even when installing python2 version
package pulls python3 dependency even when installing python2 version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-keyring (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 06:31 EST by Xavier Queralt
Modified: 2014-06-18 03:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-keyring-3.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 01:59:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Queralt 2013-11-15 06:31:54 EST
Description of problem:
python2 version of python-keyring package wrongly pulls python3 package because it is installing the python3 version of the keyring script instead of the python2 one.

Version-Release number of selected component (if applicable):
f19, f20, rawhide and probably f18

How reproducible:


Steps to Reproduce:
1. yum install python-keyring
2. rpm -q --requires python-keyring | grep python3
3. grep python3 /usr/bin/keyring

Actual results:


Expected results:


Additional info:
I think the problem comes from the installed keyring script, which is copied to python3-keyring instead of moving it in the %install section (I don't know the exact reason but it looks like the python2 version doesn't override it).
Comment 1 Christopher Meng 2013-11-15 06:39:57 EST
I'm on CC because I want to take the package and maintain.

Nowdays with more and more python3 supports, we should also care about the binary generated by setup.py.

I just do such care in my package by:

1. First build py3 version

2. Move py3 version bin from xxx to xxx-py3version(now is xxx-3.3) 

3. Build py2 version

4. Handle them in %files.

This package just got rebirth so I hope Ratnadeep can maintain it well.
Comment 2 Fedora Update System 2013-12-03 01:09:42 EST
python-keyring-3.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-keyring-3.3-1.fc19
Comment 3 Fedora Update System 2013-12-03 01:10:06 EST
python-keyring-3.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-keyring-3.3-1.fc20
Comment 4 Fedora Update System 2013-12-03 13:21:39 EST
Package python-keyring-3.3-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-keyring-3.3-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22644/python-keyring-3.3-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-12-04 01:59:38 EST
python-keyring-3.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-12-13 22:35:19 EST
python-keyring-3.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.