This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1030998 - install doesn't work for '*/binaryname' patterns
install doesn't work for '*/binaryname' patterns
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 08:03 EST by Jaroslav Škarvada
Modified: 2014-09-30 19:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-0.4.8-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-24 18:42:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2013-11-15 08:03:42 EST
Description of problem:
dnf install doesn't work for wildcards

Version-Release number of selected component (if applicable):
dnf-0.4.6-1.fc20.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf install '*/i7z'

Actual results:
Nothing to do

Expected results:
Install of i7z package

Additional info:
dnf provides '*/i7z'
i7z-0.27.2-8.fc20.x86_64 ...

yum install '*/i7z'
...install in progress

This is handy speed-up if one know the name of the binary but not the name of the package (or can't remember) and is pretty sure there will be only one match (if not he/she can still cancel the installation).
Comment 1 Ales Kozumplik 2013-11-18 02:26:23 EST
Hm, this could be either a bug in the subject parsing or something we don't do for perfomance reasons (the filename lookup is expensive, esp. if it contains globbing). We'll look into that.
Comment 2 Zdeněk Pavlas 2013-11-18 04:20:26 EST
IMO this is not a bug. Why are you using quotes when you WANT wildcards to be expanded, anyway?
Comment 3 Ales Kozumplik 2013-11-18 04:30:23 EST
It was a bug indeed.

Fixed by c388ac6, the patch will be included in dnf-0.4.8
Comment 4 Fedora Update System 2013-11-21 10:56:07 EST
dnf-0.4.8-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.8-1.fc20
Comment 5 lnie 2013-11-21 23:40:08 EST
fixed with dnf-0.4.8-1.fc20
Comment 6 Fedora Update System 2013-11-23 23:04:00 EST
Package dnf-0.4.8-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.8-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22052/dnf-0.4.8-1.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-24 18:42:11 EST
dnf-0.4.8-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.