Bug 1031006 - /etc/pulp/server/plugins.conf.d not included in katello-debug
/etc/pulp/server/plugins.conf.d not included in katello-debug
Status: CLOSED DUPLICATE of bug 1102362
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 08:16 EST by Dominic Cleal
Modified: 2015-08-17 14:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 13:09:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominic Cleal 2013-11-15 08:16:06 EST
Description of problem:
/etc/pulp/server/plugins.conf.d config files (i.e. /etc/pulp/server/plugins.conf.d/yum_importer.json) should be included in katello-debug output.

Version-Release number of selected component (if applicable):
MDP2

How reproducible:
Always

Steps to Reproduce:
1. run katello-debug
2. check contents
3.

Actual results:
no /etc/pulp/server/plugins.conf.d, only server.conf

Expected results:
/etc/pulp/server/plugins.conf.d/yum_importer.conf

Additional info:
Comment 2 Bryan Kearney 2014-06-03 13:09:59 EDT
This should be fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1102362. I am marking this as a duplicate. Please do all verification against that bug.

*** This bug has been marked as a duplicate of bug 1102362 ***
Comment 3 Alessandro Silva 2015-08-17 14:49:42 EDT
If you do not pass katello-configure --proxy-url http://yourproxy.example.com --proxy-port 3128 --proxy-user  --proxy-pass, some configuration files with proxy variable are not populated.
Comment 4 Alessandro Silva 2015-08-17 14:51:10 EDT
Once if you do not have a auth proxy, It's required to type --proxy-user  --proxy-pass

I tested it in 6.1 and the error persist.

Note You need to log in before you can comment on or make changes to this bug.