Bug 1031016 - DHT : for many operation directory/file path is '(null)' in brick log
DHT : for many operation directory/file path is '(null)' in brick log
Status: CLOSED DUPLICATE of bug 1282319
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
2.1
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nithya Balachandran
storage-qa-internal@redhat.com
:
Depends On:
Blocks: 1282319 1456361
  Show dependency treegraph
 
Reported: 2013-11-15 08:34 EST by Rachana Patel
Modified: 2017-05-29 04:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1231264 1282319 (view as bug list)
Environment:
Last Closed: 2015-11-27 07:21:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-11-15 08:34:16 EST
Description of problem:
In case of DHT volume, brick logs has '(null)' as a path for operations like OPENDIR, MKDIR, MKNOD, SETXATTR

e.g
log snippet from brick

[2013-11-14 01:52:01.592994] I [server-rpc-fops.c:705:server_opendir_cbk] 0-dht-server: 61510: OPENDIR (null) (16bb3787-361d-4977-8c66-
a62b8d2f70a3) ==> (No such file or directory)
[2013-11-14 03:14:56.011608] I [server-rpc-fops.c:528:server_mkdir_cbk] 0-dht-server: 32254: MKDIR (null) (00000000-0000-0000-0000-0000
00000001/{1.1000000}) ==> (File exists)
[2013-11-14 03:18:18.304290] I [server-rpc-fops.c:438:server_access_cbk] 0-dht-server: 47194: ACCESS (null) (2d0887f8-358d-4758-949f-db
bd06d67265) ==> (No such file or directory)
[2013-11-14 03:18:18.317609] I [server-rpc-fops.c:705:server_opendir_cbk] 0-dht-server: 47197: OPENDIR (null) (2d0887f8-358d-4758-949f-
dbbd06d67265) ==> (No such file or directory)
...
[2013-11-14 06:32:14.172144] I [server-rpc-fops.c:898:_gf_server_log_setxattr_failure] 0-dht-server: 164153: SETXATTR (null) (85258d5e-
fde6-4452-a4cf-71ef0568129a) ==> trusted.glusterfs.dht
[2013-11-14 06:32:14.174551] I [server-rpc-fops.c:528:server_mkdir_cbk] 0-dht-server: 285540: MKDIR (null) (00000000-0000-0000-0000-000
000000001/118) ==> (File exists)
[2013-11-14 06:32:14.202874] I [server-rpc-fops.c:575:server_mknod_cbk] 0-dht-server: 285551: MKNOD (null) (bf070eaf-2822-40b7-ab44-24d
91926db45/f7) ==> (File exists)

In most of the cases reason  is '(File exists)' or ' (No such file or directory)'


Version-Release number of selected component (if applicable):
============================================================= 
3.4.0.44rhs-1.el6rhs.x86_64



How reproducible:
always


Steps to Reproduce:
1.create DHT volume and mout it using FUSE and NFS
2. create, delete files/Directories from both mount point simultaneously.
3. Keep checking logs.

Actual results:
for many operation directory/file path is  '(null)' in brick  log 

Expected results:
It should show path of that Dir/file

Additional info:
Comment 3 Amar Tumballi 2013-12-02 05:09:24 EST
(null) in here is the 'path' of the file. Yes it could have not been printed at all as a proper fix.

Above there are two type of operations:

inode ops (Access, opendir etc), where there is a log of 'gfid' which can help people to debug. (Also, these calls may be also path less, gfid only fops)..

in entry ops: (mkdir and mknod), the gfid of parent, and basename is logged to help debugging.
Comment 7 Susant Kumar Palai 2015-11-27 07:21:58 EST

*** This bug has been marked as a duplicate of bug 1282319 ***

Note You need to log in before you can comment on or make changes to this bug.