Bug 1031100 - Domain mode: Restart of the managed server fails with read timed out
Domain mode: Restart of the managed server fails with read timed out
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER07
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-11-15 10:42 EST by Radim Hatlapatka
Modified: 2014-01-02 15:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2013-11-15 10:42:51 EST
Description of problem:
There is 20s limit for restarting server (20s it took to JON server to report the read timed out error). But sometimes it takes longer thus ending up with error [1]. For example in my test it took 30s


[1]
java.lang.Exception: Read timed out, rolled-back=false, rolled-back=false at org.rhq.core.pc.operation.OperationInvocation.run(OperationInvocation.java:278) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:724)

Version-Release number of selected component (if applicable): JON 3.2.0.ER5 vs EAP 6.1.1


How reproducible: 10 % (mostly happens on solaris sparc 10)


Steps to Reproduce:
1. Import EAP 6 in domain mode
2. restart one of the managed servers (e.g. server-one)


Actual results:
restart shown as failed due Read timed out because restart took longer than 20s 

Expected results:
No failure if restart is successful even if it took a little bit longer


Additional info:
The best way would be to make similar fix as was done for https://bugzilla.redhat.com/show_bug.cgi?id=911327

It could be good also to increase the timeout for stop and start operation on the managed server
Comment 1 Thomas Segismont 2013-11-18 06:19:11 EST
Fixed in master

commit 09d3e4fc3fd3350364a2eca08ad8714202d9f48d
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Mon Nov 18 12:15:35 2013 +0100
Comment 2 Thomas Segismont 2013-11-18 08:46:46 EST
Cherry-picked to release/jon3.2.x

commit e14361863f517bca0e8b3208f1f424200768b777
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Mon Nov 18 12:15:35 2013 +0100
Comment 3 Simeon Pinder 2013-11-19 10:47:59 EST
Moving to ON_QA as available for testing with new brew build.
Comment 4 Simeon Pinder 2013-11-22 00:13:36 EST
Mass moving all of these from ER6 to target milestone ER07 since the ER6 build was bad and QE was halted for the same reason.
Comment 5 Radim Hatlapatka 2013-11-27 11:31:39 EST
I am not able to hit the issue any more with JON 3.2.0.ER7

Note You need to log in before you can comment on or make changes to this bug.