Bug 1031106 - Left dock toolbox shrinks horizontally when attached panel to another column
Left dock toolbox shrinks horizontally when attached panel to another column
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 916604
  Show dependency treegraph
 
Reported: 2013-11-15 10:53 EST by Nils Philippsen
Modified: 2016-10-14 06:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 916604
Environment:
Last Closed: 2016-10-14 06:29:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 724130 None None None Never

  None (edit)
Description Nils Philippsen 2013-11-15 10:53:25 EST
+++ This bug was initially created as a clone of Bug #916604 +++

Description of problem:
The Gimp 2.8 has a new feature to attach the toolbar into several columns. When I attached Tool option panel (in default under the Toolbox) to the right side of the Toolbox (the toolbox and tool options are now horizontally, not vertically as before), the toolbox shrinks into one column of tool icons and expand horizontally behind the monitor borders. It's especially annoying in single window mode, when in does not permit the fullsreen mode.

Version-Release number of selected component (if applicable):
gimp-2.8.2-6.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start gimp
2. Enable single-window mode (Windows -> Single-Window mode)
3. Drag&drop the Tool options (by default under the Toolbox) from its original position right side of the Toolbox
4. Try to maximize of F11 to fullscreen

Actual results:
The Toolbox shrinks and you are unable to resize the gimp vertically. The fullscreen does not work at all and behaves weird

Expected results:
The gimp should now the maximal height of the monitor and if the shrunk toolbox does fit the height, it should expand a bit to the width.

Additional info:

--- Additional comment from Nils Philippsen on 2013-11-15 10:43:32 EST ---

The reason for this is that moving the tool options dockable to the right "squeezes" the toolbox so it's only one column wide, but very tall (too tall for most displays), which results in e.g. GNOME Shell refusing to "maximize" the window, i.e. fit it into the current display, which it can't because the window is already taller than the display.

Here's a workaround: After step 3, there's a handle to the right side of the tool options dockable. Drag it to the right, creating some space for the toolbar so it can use additional columns. Then you should be able to reduce the window height, or maximize it.

I'll clone this for Fedora, and raise this with upstream -- I'm not familiar with the UI layout code and can't estimate how much effort it would be to fix this.
Comment 1 Nils Philippsen 2013-11-15 10:57:50 EST
Adding FutureFeature so this bug isn't closed automatically.
Comment 2 Nils Philippsen 2016-10-14 06:29:35 EDT
I don't see how I could fix this and it's reported upstream, closing.

Note You need to log in before you can comment on or make changes to this bug.