Bug 1031150 - x2goserver init script needs stop and to create /tmp/.X11-unix/ directory
x2goserver init script needs stop and to create /tmp/.X11-unix/ directory
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: x2goserver (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 12:41 EST by Scott Dowdle
Modified: 2014-01-03 02:41 EST (History)
1 user (show)

See Also:
Fixed In Version: x2goserver-4.0.1.9-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 02:41:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2013-11-15 12:41:51 EST
I worked with orionp in #x2go IRC channel and he wanted me to file a bug because we discovered that the /etc/init.d/x2gocleansessions script doesn't seem to:

1) stop properly

and 

2) doesn't create /tmp/.X11-unix/

After manually killing the process... removing the lock file, and then manually creating the /tmp/.X11-unix/ dir as root.root 1777 I could connect with x2go client.  Without that, not so much.
Comment 1 Fedora Update System 2013-11-24 16:29:32 EST
x2goserver-4.0.1.8-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/x2goserver-4.0.1.8-1.el6
Comment 2 Fedora Update System 2013-11-25 15:13:03 EST
Package x2goserver-4.0.1.8-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing x2goserver-4.0.1.8-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12186/x2goserver-4.0.1.8-1.el6
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-11-27 20:05:38 EST
x2goserver-4.0.1.8-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/x2goserver-4.0.1.8-2.fc20
Comment 4 Fedora Update System 2013-11-27 20:05:52 EST
x2goserver-4.0.1.8-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/x2goserver-4.0.1.8-2.el6
Comment 5 Fedora Update System 2013-11-27 20:06:05 EST
x2goserver-4.0.1.8-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/x2goserver-4.0.1.8-2.fc19
Comment 6 Fedora Update System 2014-01-03 02:41:11 EST
x2goserver-4.0.1.9-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.