Bug 1031151 - NetworkManager Mobile Broadband connection handling is flaky
NetworkManager Mobile Broadband connection handling is flaky
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 13:01 EST by Samium Gromoff
Modified: 2015-06-29 08:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 08:56:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from "journalctl --since today" after the experiment. (420.52 KB, text/plain)
2013-12-06 05:32 EST, Göran Uddeborg
no flags Details
Output from "mmcli -m 0" (1.72 KB, text/plain)
2013-12-06 05:35 EST, Göran Uddeborg
no flags Details

  None (edit)
Description Samium Gromoff 2013-11-15 13:01:31 EST
Description of problem:

Initiation of a "Mobile Broadband" connection is flaky -- the user has to click
"Mobile Broadband" -> "Connect" more than once, for the connection to succeed,
even if the signal is strong enough.

Version-Release number of selected component (if applicable):
Name        : NetworkManager
Version     : 0.9.9.0
Release     : 15.git20131003.fc20
Name        : ModemManager
Version     : 1.1.0
Release     : 2.git20130913.fc20

How reproducible:
Connection initiation fails _very_ frivolously, but is stable, once established.  

Steps to Reproduce:

1. Buy an Ericsson H5321 gw 3G modem -- not sure about how others fare
2. Try to initiate a 3G connection -- imperfect conditions might amplify the issue, I guess

Actual results:

"Mobile Broadband" takes several "Connect" clicks to succeed.

Expected results:

"Mobile Broadband" should take a single "Connect" click to succeed.

Additional info:

from `lsusb`:
Bus 003 Device 035: ID 0bdb:1926 Ericsson Business Mobile Networks BV 
Device Descriptor:
  bcdUSB               2.00
  idVendor           0x0bdb Ericsson Business Mobile Networks BV
  idProduct          0x1926 
  iManufacturer           1 Lenovo
  iProduct                2 H5321 gw
Comment 1 Göran Uddeborg 2013-12-06 05:32:48 EST
Created attachment 833556 [details]
Output from "journalctl --since today" after the experiment.
Comment 2 Göran Uddeborg 2013-12-06 05:34:08 EST
I'm having similar experiences with the same hardware.  I'm trying to give you some more information to debug the issue.  I provide the output of "mmcli".  I also provide the output of "journalctl --since today" after having done the following steps:

1 Boot
2 Connect from panel.  It says the broadband is "inactive" before I click.  This fails.
3 Connect from the panel again.  This time it says the broadband is "off" before I connect.  This time it succeeds.
4 Disconnect from panel.
5 Connect again from panel.  This fails immediately.
6 Repeat 5, same result.
7 Open "network settings" dialog, and turn off the broadband in there.
8 Turn on in n-s.  Now it believes it is connected; the panel indicates that for example.  But I can't get anywhere over the net.
9 Turn off in n-s.
10 Turn on in n-s.  Fails
11 Connect from panel.  Fails
12 Turn off and on in n-s.
13 Connect from panel, fails.
14 Turn off the computer.
15 Turn on the computer.
16 Connect from panel.  Fails as in 2.
17 Connect from panel.  Succeeds as in 3.

End of experiment.  Previous days when I have tried to get this to work I've seen in the output of journalctl that NetworkManager has tried to use dhclient to get an IP address.  That too always fails.  In today's experiment, that didn't occur.
Comment 3 Göran Uddeborg 2013-12-06 05:35:28 EST
Created attachment 833557 [details]
Output from "mmcli -m 0"

Installed packages:
NetworkManager-0.9.9.0-20.git20131003.fc20.x86_64
ModemManager-1.1.0-2.git20130913.fc20.x86_64
Comment 4 Fedora End Of Life 2015-05-29 05:46:29 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2015-06-29 08:56:35 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.