Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1031161

Summary: katello-configure does not set proxy for pulp puppet importer
Product: Red Hat Satellite Reporter: Yasser Nabi <yassersaleemi>
Component: InstallationAssignee: Eric Helms <ehelms>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0.2CC: bkearney, cwelton, mmccune
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Linux   
URL: http://projects.theforeman.org/issues/6133
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-16 21:42:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Yasser Nabi 2013-11-15 18:35:38 UTC
Description of problem:

When specifying a proxy with katello-configure, it correctly sets a proxy for yum_importer.json but no proxy configuration is saved for puppet. Thus preventing importing puppeforge when running behind a proxy.


Version-Release number of selected component (if applicable):
Satellite 6.0.2 (MDP2), but also found in in latest upstream in Katello Git repo

How reproducible:
katello-configure --proxy-url=http://some.http.proxy --proxy-port=8080
/etc/pulp/server/plugins.conf.d/puppet_importer.json does not exist and sync with puppetforge fails


Steps to Reproduce:
1. katello-configure --proxy-url=http://some.http.proxy --proxy-port=8080
2. Run puppetforge repo sync
3. After a period, nectar will timeout and sync will fail

Actual results:
Puppet repo sync failure

Expected results:
Puppet Forge modules to be synced

Comment 1 Yasser Nabi 2013-11-15 18:42:37 UTC
Just added a pull request:

https://github.com/Katello/katello-installer/pull/65

Comment 2 RHEL Program Management 2013-11-15 18:45:41 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Mike McCune 2014-06-03 19:23:03 UTC
We need to ensure with the rewritten katello-installer that proxy based setups still work.

Comment 6 Eric Helms 2014-06-09 22:43:36 UTC
Created redmine issue http://projects.theforeman.org/issues/6133 from this bug

Comment 7 Mike McCune 2014-06-16 21:42:17 UTC

*** This bug has been marked as a duplicate of bug 1083818 ***