This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1031161 - katello-configure does not set proxy for pulp puppet importer
katello-configure does not set proxy for pulp puppet importer
Status: CLOSED DUPLICATE of bug 1083818
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.2
Unspecified Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Eric Helms
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 13:35 EST by Yasser Nabi
Modified: 2016-04-22 13:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 17:42:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6133 None None None 2016-04-22 13:01 EDT

  None (edit)
Description Yasser Nabi 2013-11-15 13:35:38 EST
Description of problem:

When specifying a proxy with katello-configure, it correctly sets a proxy for yum_importer.json but no proxy configuration is saved for puppet. Thus preventing importing puppeforge when running behind a proxy.


Version-Release number of selected component (if applicable):
Satellite 6.0.2 (MDP2), but also found in in latest upstream in Katello Git repo

How reproducible:
katello-configure --proxy-url=http://some.http.proxy --proxy-port=8080
/etc/pulp/server/plugins.conf.d/puppet_importer.json does not exist and sync with puppetforge fails


Steps to Reproduce:
1. katello-configure --proxy-url=http://some.http.proxy --proxy-port=8080
2. Run puppetforge repo sync
3. After a period, nectar will timeout and sync will fail

Actual results:
Puppet repo sync failure

Expected results:
Puppet Forge modules to be synced
Comment 1 Yasser Nabi 2013-11-15 13:42:37 EST
Just added a pull request:

https://github.com/Katello/katello-installer/pull/65
Comment 2 RHEL Product and Program Management 2013-11-15 13:45:41 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Mike McCune 2014-06-03 15:23:03 EDT
We need to ensure with the rewritten katello-installer that proxy based setups still work.
Comment 6 Eric Helms 2014-06-09 18:43:36 EDT
Created redmine issue http://projects.theforeman.org/issues/6133 from this bug
Comment 7 Mike McCune 2014-06-16 17:42:17 EDT

*** This bug has been marked as a duplicate of bug 1083818 ***

Note You need to log in before you can comment on or make changes to this bug.