Bug 1031173 - jboss-cli.bat does not work when EAP installed into directory with spaces
jboss-cli.bat does not work when EAP installed into directory with spaces
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CLI (Show other bugs)
6.2.0
Unspecified Windows
unspecified Severity high
: DR0
: EAP 6.3.0
Assigned To: Alexey Loubyansky
Petr Kremensky
Russell Dickenson
:
: 1033200 (view as bug list)
Depends On:
Blocks: 1058410
  Show dependency treegraph
 
Reported: 2013-11-15 14:38 EST by Miles Tjandrawidjaja
Modified: 2015-07-30 05:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The `jboss-cli` tool would not launch successfully on Microsoft Windows if JBoss EAP 6 was installed in a directory that had spaces or other special characters such as parentheses in its path. For example, the following error message was displayed if JBoss EAP 6 was installed in the directory `C:\JBoss EAP\jboss-eap-6.2`: ---- Error: Could not find or load main class EAP\jboss-eap-6.2\bin\jboss-cli-logging.properties ---- This issue has been fixed in this release by changing how the `jboss-cli` tool declares and uses file paths on Microsoft Windows. As a result, it can be used without workarounds in JBoss EAP 6 installations in directories that have spaces or other special characters in their path on Microsoft Windows systems.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:30:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miles Tjandrawidjaja 2013-11-15 14:38:45 EST
Description of problem:
Canot run jboss-cli.bat on Windows when EAP unziped into directory with spaces

Version-Release number of selected component (if applicable):
Tested with jboss-as-dist-7.3.0.Final-redhat-10.zip
and then check with  jboss-as-dist-7.3.0.Final-redhat-12.zip

Zips can be downloaded from
http://download.eng.bos.redhat.com/brewroot/repos/jb-eap-6-rhel-6-build/latest/maven/org/jboss/as/jboss-as-dist/

Steps to Reproduce:
1.On Windows 7 unzip EAP into directory with spaces.
  Ex. C:\Users\John\Bug Example
2.Run C:\Users\John\Bug Example\jboss-eap-6.2\bin\jboss-cli.bat


Actual results:
Error: Could not find or load main class Example\jboss-eap-6.2\bin\jboss-cli-log
ging.properties
Press any key to continue . . .

Expected results:
You are disconnected at the moment. Type 'connect' to connect to the server or '
help' for the list of supported commands.
[disconnected /]

Additional info:
In jboss-cli.bat
set "JAVA_OPTS=%JAVA_OPTS% -Djboss.modules.system.pkgs=com.sun.java.swing"

Changed to 
set "JAVA_OPTS=%JAVA_OPTS% -Djboss.modules.system.pkgs=com.sun.java.swing -Dlogging.configuration=file:%JBOSS_HOME%\bin\jboss-cli-logging.properties"
Comment 3 Brian Stansberry 2013-11-21 16:33:05 EST
*** Bug 1033200 has been marked as a duplicate of this bug. ***
Comment 4 Petr Kremensky 2013-12-02 02:56:14 EST
Please include there is a simple workaround for the issue, see
https://github.com/jbossas/jboss-eap/pull/712/files
Comment 5 Petr Kremensky 2013-12-02 08:22:11 EST
Also special characters like parentheses are problem here, we should add this to RN as well.
Comment 7 Petr Kremensky 2014-02-18 09:28:11 EST
Verified on EAP 6.3.0.DR0

Note You need to log in before you can comment on or make changes to this bug.