Bug 1031188 - Support classic mode for saved sessions
Support classic mode for saved sessions
Status: CLOSED DUPLICATE of bug 1031182
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-session (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 15:50 EST by Matthias Clasen
Modified: 2014-01-15 05:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-08 13:48:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 720894 None None None Never

  None (edit)
Description Matthias Clasen 2013-11-15 15:50:18 EST
We ship a mechanism for customers to run named sessions by choosing 'custom session' from the session chooser on the login screen.

In RHEL7, we need to allow saved sessions to be either classic or gnome.

Here is how we should go about it:

1) When saving a session, write the 'classic' marker file to the saved session directory
2) In gnome-session-custom-session, look for the file ~/.config/gnome-session/saved-session/classic'. If it exists, pass --session gnome-classic to gnome-session
Comment 1 Ray Strode [halfline] 2014-01-08 13:48:22 EST
let's just dupe this with bug 1031182 since the bugs are pretty closely related.

*** This bug has been marked as a duplicate of bug 1031182 ***

Note You need to log in before you can comment on or make changes to this bug.