This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1031227 - Reduce lock scope in retro changelog plug-in
Reduce lock scope in retro changelog plug-in
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 18:24 EST by Nathan Kinder
Modified: 2014-06-17 23:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.1.6-12.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2013-11-15 18:24:09 EST
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47599

Looks like the locking in the retro changelog code is too big - write_replog_db - the retrocl_internal_lock lock scope is very large.  Or perhaps even get rid of locking and use atomics.

We are seeing deadlock issues related to this as described in the following FreeIPA ticket:

    https://fedorahosted.org/freeipa/ticket/3967
Comment 1 Sankar Ramalingam 2013-11-25 12:37:41 EST
Can this be verified on DS environment?
Comment 2 mreynolds 2013-11-25 15:04:59 EST
Hi Sankar,

There is nothing to verify or reproduce for this bug.
Comment 4 Sankar Ramalingam 2014-02-13 11:47:51 EST
Marking the bug as Verified as sanity only. No regression found with the latest builds of 389-ds-base-1.3.1.6-18.
Comment 5 Ludek Smid 2014-06-13 09:24:48 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.