Bug 1031235 - [abrt] WARNING: CPU: 2 PID: 646 at drivers/gpu/drm/i915/intel_display.c:8329 check_crtc_state+0x5af/0x9f0 [i915]()
[abrt] WARNING: CPU: 2 PID: 646 at drivers/gpu/drm/i915/intel_display.c:8329 ...
Status: CLOSED DUPLICATE of bug 1027037
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6ac9c791dedad39a308757bf8ea...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 20:33 EST by i.a.lazarev
Modified: 2014-11-18 15:18 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 15:18:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (74.45 KB, text/plain)
2013-11-15 20:33 EST, i.a.lazarev
no flags Details

  None (edit)
Description i.a.lazarev 2013-11-15 20:33:06 EST
Additional info:
reporter:       libreport-2.1.9
WARNING: CPU: 2 PID: 646 at drivers/gpu/drm/i915/intel_display.c:8329 check_crtc_state+0x5af/0x9f0 [i915]()
pipe state doesn't match!
Modules linked in: fuse nf_conntrack_ftp nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6t_REJECT xt_conntrack rfcomm bnep ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw x86_pkg_temp_thermal coretemp kvm_intel kvm snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_hda_codec_hdmi snd_hda_codec_idt arc4 ath9k ath9k_common snd_hda_intel snd_hda_codec snd_hwdep crc32_pclmul crc32c_intel ghash_clmulni_intel ath9k_hw ath iTCO_wdt mac80211 snd_seq snd_seq_device hp_accel ath3k btusb bluetooth snd_pcm cfg80211 hp_wmi sparse_keymap rfkill r8169 mii iTCO_vendor_support sdhci_pci sdhci mmc_core lpc_ich mfd_core jmb38x_ms memstick microcode uvcvideo videobuf2_vmalloc videobuf2_memops serio_raw videobuf2_core snd_page_alloc videodev media lis3lv02d mperf snd_timer snd mei_me mei shpchp wmi joydev soundcore input_polldev uinput binfmt_misc hid_logitech_dj i915 i2c_algo_bit drm_kms_helper drm i2c_core video
CPU: 2 PID: 646 Comm: Xorg Not tainted 3.11.7-200.fc19.x86_64 #1
Hardware name: Hewlett-Packard HP ProBook 4540s/17F6, BIOS 68IRR Ver. F.31 08/31/2012
 0000000000000009 ffff88012bed1898 ffffffff8164777b ffff88012bed18e0
 ffff88012bed18d0 ffffffff8106715d ffff8801375616d0 0000000000000001
 ffff8801371e2000 ffff880137561000 ffff8801371e2478 ffff88012bed1930
Call Trace:
 [<ffffffff8164777b>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff810671cc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa00add4f>] check_crtc_state+0x5af/0x9f0 [i915]
 [<ffffffffa00b8f73>] intel_modeset_check_state+0x2c3/0x7a0 [i915]
 [<ffffffffa00b94c5>] intel_set_mode+0x25/0x30 [i915]
 [<ffffffffa00b9d12>] intel_crtc_set_config+0x742/0x920 [i915]
 [<ffffffffa002ca6d>] drm_mode_set_config_internal+0x5d/0xe0 [drm]
 [<ffffffffa002f447>] drm_mode_setcrtc+0xf7/0x650 [drm]
 [<ffffffffa00aebb2>] ? intel_crtc_load_lut+0xd2/0x170 [i915]
 [<ffffffffa0020142>] drm_ioctl+0x532/0x660 [drm]
 [<ffffffff811b9e9d>] do_vfs_ioctl+0x2dd/0x4b0
 [<ffffffff8108c201>] ? __hrtimer_start_range_ns+0x351/0x3e0
 [<ffffffff811ba0f1>] SyS_ioctl+0x81/0xa0
 [<ffffffff81656999>] system_call_fastpath+0x16/0x1b
Comment 1 i.a.lazarev 2013-11-15 20:33:21 EST
Created attachment 824774 [details]
File: dmesg
Comment 2 Michele Baldessari 2013-11-17 09:17:30 EST
Hi,

can you reproduce this issue at will?

The following commit (hasn't hit stable yet but has been CCed) might
be relevant:
commit c9976dcf55c8aaa7037427b239f15e5acfc01a3a
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Sep 29 19:15:07 2013 +0100

    drm/i915: Only apply DPMS to the encoder if enabled


hth,
Michele
Comment 3 Adam Jackson 2014-11-18 15:18:58 EST

*** This bug has been marked as a duplicate of bug 1027037 ***

Note You need to log in before you can comment on or make changes to this bug.