Bug 1031239 - F20 systems often slow to shut down
F20 systems often slow to shut down
Status: CLOSED DUPLICATE of bug 1023820
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-11-15 21:16 EST by Adam Williamson
Modified: 2013-12-17 14:42 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-12-17 14:42:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
log of slow shutdown (371.95 KB, text/plain)
2013-11-15 22:02 EST, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-11-15 21:16:16 EST
In Fedora 20 validation testing, I've noticed quite often my systems - usually virt-manager VMs - are very slow to shut down. It seems to be getting worse: I booted F20 Beta TC5 desktop live image 7 times and got slow shutdown only twice, booted F20 Final TC1 desktop live image multiple times and got slow shutdown every single time.

Either way, whenever the shutdown is slow, if I send systemd debug logs to a serial console so I can see what's going on, it seems to be stuck on:

"A stop job is running for User Manager for 1000"

i.e. /lib/systemd/system/user@.service . Haven't managed to diagnose anything further than that yet.
Comment 1 Adam Williamson 2013-11-15 21:16:56 EST
I see the red asterisks shuttling from side to side next to that message - an indication that job is still ongoing - for about 2 minutes before the system finally shuts down. Nothing else seems to slow down the shutdown process.
Comment 2 Adam Williamson 2013-11-15 22:02:24 EST
Created attachment 824778 [details]
log of slow shutdown

Following the instructions at http://freedesktop.org/wiki/Software/systemd/Debugging/ , here's the log of a slow shutdown. Note the initiation of shutdown at 132 and then the long pause before user@1000.service shutdown fails at 222 - looks like a 90 second timeout.
Comment 3 Alexey Torkhov 2013-12-17 14:11:09 EST
This seems to be duplicate of bug 1023820.
Comment 4 Adam Williamson 2013-12-17 14:42:35 EST
I think you're right. Thanks.

*** This bug has been marked as a duplicate of bug 1023820 ***

Note You need to log in before you can comment on or make changes to this bug.