Bug 1031244 - x11vnc failed to work after recent updates [NEEDINFO]
x11vnc failed to work after recent updates
Status: NEW
Product: Fedora EPEL
Classification: Fedora
Component: x11vnc (Show other bugs)
el6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 23:18 EST by Cecil Yen
Modified: 2013-11-22 03:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pahan: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Cecil Yen 2013-11-15 23:18:43 EST
Description of problem:
x11vnc would disconnect the client after random period of time

Version-Release number of selected component (if applicable):
x11vnc 0.9.13-8.el6.x86_64.rpm

How reproducible:
Connect the remote CentOS 6 machine via ssh and tunnel the x11vnc to localhost. VNC client would be disconnected after tens of seconds. Tried three clients on Mac, all the same. SSH and tunneling worked just fine.

Additional info:
It worked well until the most recent update. Maybe the latest Xorg update broke the compatibility.
Comment 1 Pavel Alexeev 2013-11-16 14:51:50 EST
Please attach logs and some errors what you see.
There was not x11vnc updates long time.
Comment 2 Pavel Alexeev 2013-11-16 14:52:01 EST
Please attach logs and some errors what you see.
There was not x11vnc updates long time.
Comment 3 Cecil Yen 2013-11-17 12:45:53 EST
There is nothing extraordinary in stdout of x11vnc, message, or .xsession-errors. x11vnc just said the client was disconnected and the client was disconnected for no reason. It happened randomly; sometimes the session last few second or tens of seconds. I am sure ssh connection was good since regular VNC server worked fine.  Actually, x11vnc worked just fine before a system update of some Xorg packages and few other components like kernel and Nvidia driver.
Comment 4 Pavel Alexeev 2013-11-22 03:44:51 EST
Really I have no idea how to debug it without any info. Could you please run x11vnc with -verbose key and then look at relevant messages at failure?

Note You need to log in before you can comment on or make changes to this bug.