Bug 1031275 - python-django-tinymce-2.3.0 is available
python-django-tinymce-2.3.0 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-django-tinymce (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Infrastructure SIG
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks: PYTHON3 PY3PATCH-AVAILABLE
  Show dependency treegraph
 
Reported: 2013-11-16 05:12 EST by Upstream Release Monitoring
Modified: 2016-08-20 13:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-20 13:52:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 2.0.6 (#1031275) (1.21 KB, patch)
2015-11-12 07:10 EST, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 2.2.0 (#1031275) (1.21 KB, patch)
2015-12-23 07:12 EST, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.0 including Python 3 subpackage (3.43 KB, patch)
2016-08-03 11:55 EDT, Jan Beran
no flags Details | Diff
Updated spec file (3.46 KB, patch)
2016-08-17 14:46 EDT, Jan Beran
no flags Details | Diff
Updated specfile (3.59 KB, text/x-matlab)
2016-08-18 04:59 EDT, Lumír Balhar
no flags Details

  None (edit)
Description Upstream Release Monitoring 2013-11-16 05:12:59 EST
Latest upstream release: 1.5.2
Current version/release in Fedora Rawhide: 1.5.1b4-2.fc20
URL: https://pypi.python.org/packages/source/d/django-tinymce/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2014-09-22 04:50:17 EDT
Latest upstream release: 1.5.3
Current version/release in Fedora Rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/packages/source/d/django-tinymce/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring Soon this service will be implemented by a new system: https://github.com/fedora-infra/anitya/
It will require to manage monitored projects via a new web interface. Please make yourself familiar with the new system to ease the transition.
Comment 2 Upstream Release Monitoring 2015-07-23 20:11:07 EDT
Latest upstream release: 2.0.0
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 3 Upstream Release Monitoring 2015-07-23 20:11:12 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-5HcsUl/python-django-tinymce.spec
return code:  22
stdout:
Getting http://pypi.python.org/packages/source/d/django-tinymce/django-tinymce-2.0.0.tar.gz to ./django-tinymce-2.0.0.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 4 Upstream Release Monitoring 2015-07-24 08:10:47 EDT
Latest upstream release: 2.0.1
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 5 Upstream Release Monitoring 2015-07-24 08:10:56 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-qLJg9c/python-django-tinymce.spec
return code:  22
stdout:
Getting http://pypi.python.org/packages/source/d/django-tinymce/django-tinymce-2.0.1.tar.gz to ./django-tinymce-2.0.1.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 6 Upstream Release Monitoring 2015-07-26 20:10:46 EDT
Latest upstream release: 2.0.2
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 7 Upstream Release Monitoring 2015-07-26 20:10:56 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-9pcnqa/python-django-tinymce.spec
return code:  22
stdout:
Getting http://pypi.python.org/packages/source/d/django-tinymce/django-tinymce-2.0.2.tar.gz to ./django-tinymce-2.0.2.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 8 Upstream Release Monitoring 2015-08-06 08:10:46 EDT
Latest upstream release: 2.0.3
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 9 Upstream Release Monitoring 2015-08-06 08:10:55 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-QtAlfI/python-django-tinymce.spec
return code:  22
stdout:
Getting http://pypi.python.org/packages/source/d/django-tinymce/django-tinymce-2.0.3.tar.gz to ./django-tinymce-2.0.3.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 10 Upstream Release Monitoring 2015-08-07 08:11:06 EDT
Latest upstream release: 2.0.4
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 11 Upstream Release Monitoring 2015-08-07 08:11:12 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-rCSsZz/python-django-tinymce.spec
return code:  22
stdout:
Getting http://pypi.python.org/packages/source/d/django-tinymce/django-tinymce-2.0.4.tar.gz to ./django-tinymce-2.0.4.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 12 Upstream Release Monitoring 2015-09-09 20:11:29 EDT
Latest upstream release: 2.0.5
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 13 Upstream Release Monitoring 2015-09-09 20:11:36 EDT
Failed to kick off scratch build.

cmd:  sha256sum /var/tmp/thn-4ADOl2/100.0%
return code:  1
stdout:

stderr:
sha256sum: /var/tmp/thn-4ADOl2/100.0%: No such file or directory
Comment 14 Upstream Release Monitoring 2015-11-12 07:10:29 EST
Latest upstream release: 2.0.6
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 15 Upstream Release Monitoring 2015-11-12 07:10:38 EST
Created attachment 1093232 [details]
[patch] Update to 2.0.6 (#1031275)
Comment 16 Upstream Release Monitoring 2015-11-12 07:12:29 EST
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=11803816
Comment 17 Upstream Release Monitoring 2015-12-23 07:11:47 EST
Latest upstream release: 2.2.0
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 18 Upstream Release Monitoring 2015-12-23 07:12:03 EST
Created attachment 1108959 [details]
[patch] Update to 2.2.0 (#1031275)
Comment 19 Upstream Release Monitoring 2015-12-23 07:14:06 EST
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=12294052
Comment 20 Upstream Release Monitoring 2016-03-10 19:12:24 EST
Latest upstream release: 2.3.0
Current version/release in rawhide: 1.5.2-2.fc21
URL: https://pypi.python.org/pypi/django-tinymce

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 21 Upstream Release Monitoring 2016-03-10 19:12:30 EST
Patching or scratch build for python-django-tinymce and version 1.5.2 FAILED.
See for details
Comment 22 Upstream Release Monitoring 2016-03-10 19:12:31 EST
Rebase helper failed.
See logs and attachments in this bugzilla global name 'os' is not defined
Comment 23 Upstream Release Monitoring 2016-03-10 19:12:33 EST
Patches were not touched. All were applied properly
Comment 24 Fedora Admin XMLRPC Client 2016-04-04 16:27:34 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 25 Petr Viktorin 2016-04-13 10:55:24 EDT
The latest version of django-tinymce has support for Python 3. As per the Python packaging guidelines, please add a Python 3 subpackage when updating.

Let me know if you need more information or help with this.
Comment 26 Jan Beran 2016-08-03 11:55 EDT
Created attachment 1187117 [details]
Update to 2.3.0 including Python 3 subpackage

The patch includes
- update to version 2.3.0
- source update
- modernized specfile with Python 3 packaging
Comment 27 Lumír Balhar 2016-08-15 05:58:40 EDT
Hello.

Thank you for your work. I've found two problems during the review of new specfile.

- Build of package fails because tests have some unresolved dependency: ImportError: No module named django.test.utils. I've tried to find related package in Fedora but without success.

- Requires have to be in %package section for each package.

But when I comment %check section and move Requires to the right place, everything looks good.
Comment 28 Jan Beran 2016-08-17 14:46 EDT
Created attachment 1191730 [details]
Updated spec file

Hi Lumír,

thank you for the review. I fixed the requires to be in %package section for each package in the attached spec file.

However, I do not understand the error related to the missing package in the tests. There is no error from rpmbuild on my machine under Fedora 24 - everything works fine including all tests.
Comment 29 Lumír Balhar 2016-08-18 04:57:50 EDT
Hello.

I've found a problem. The problem is in missing build dependency python[23]-django because module django.test.utils mentioned in ImportError message is provided by those packages.
Another missing dependency is python[23]-mock.

I am not sure how you can had successful build - maybe you have this packages already installed on your machine? Then would be better to use mock on local machine or Koji scratch builds for check.

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15294053

I am gonna provide updated specfile.
Comment 30 Lumír Balhar 2016-08-18 04:59 EDT
Created attachment 1191826 [details]
Updated specfile

Providing updated specfile.

If maintainer has nothing against, we can push this changes after a week.
Comment 31 Kevin Fenzi 2016-08-20 13:52:06 EDT
Looks fine. Pushed and built in rawhide. 

Thanks!

Note You need to log in before you can comment on or make changes to this bug.