Bug 1031279 - python-mwlib-0.15.14 is available
python-mwlib-0.15.14 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-mwlib (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian Weller
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 05:16 EST by Upstream Release Monitoring
Modified: 2015-02-09 00:32 EST (History)
3 users (show)

See Also:
Fixed In Version: python-mwlib-0.15.14-1.fc21
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-09 00:32:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to 0.15.14 and enable tests (3.73 KB, patch)
2015-01-30 11:48 EST, Zbigniew Jędrzejewski-Szmek
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2013-11-16 05:16:30 EST
Latest upstream release: 0.15.12
Current version/release in Fedora Rawhide: 0.15.11-2.fc20
URL: https://pypi.python.org/packages/source/m/mwlib/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2014-01-10 05:21:49 EST
Latest upstream release: 0.15.13
Current version/release in Fedora Rawhide: 0.15.11-2.fc20
URL: https://pypi.python.org/packages/source/m/mwlib/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 2 Upstream Release Monitoring 2014-01-13 08:46:05 EST
Latest upstream release: 0.15.14
Current version/release in Fedora Rawhide: 0.15.11-2.fc20
URL: https://pypi.python.org/packages/source/m/mwlib/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 3 Zbigniew Jędrzejewski-Szmek 2015-01-30 11:48:18 EST
Created attachment 986079 [details]
Update to 0.15.14 and enable tests

I was trying to enable tests, in scope of #1183366. Attached patch updates to 0.15.14 and runs the test suite in %check.

The tests which didn't pass are filtered out. Two are obvious (missing dependencies), and the third seems to be an upstream error (https://github.com/pediapress/mwlib/issues/51).

I'll be happy to push this and make an update myself if you prefer.
Comment 4 Ian Weller 2015-01-30 12:55:50 EST
(In reply to Zbigniew Jędrzejewski-Szmek from comment #3)
> I'll be happy to push this and make an update myself if you prefer.

Looks good to me -- feel free to do so. Let me know if you need any ACLs.
Comment 5 Zbigniew Jędrzejewski-Szmek 2015-01-30 13:26:38 EST
Thanks, pushed to rawhide. I added myself to watch list.

What about F21? I'd update that too.
Comment 6 Ian Weller 2015-01-30 14:17:38 EST
I'll let that be your call:

http://fedoraproject.org/wiki/Updates_Policy
Comment 7 Zbigniew Jędrzejewski-Szmek 2015-01-30 14:23:01 EST
OK, I'll push it then.

The shortlog shows that changes are minuscule and bugfix in nature:
* a880af19f5 (tag: 0.15.14) prepare 0.15.14
* 45672a8b78 set user agent from environment variable MWLIB_USER_AGENT
* f39244003a (tag: 0.15.13) prepare 0.15.13
* 4e9c8ca2f6 add --disable-all-writers argument to nserve
* f6dfda0500 add note about professional support
* 3f0ee42b89 adapt bot filtering a bit
* 8d97a5738f (tag: 0.15.12) gitignore junit files
* 9609476a2c prepare 0.15.12
* 837d499149 workaround 'first run' tox issue
* 023ffc5713 fix tests with new wsgi_intercept 0.6 and require that version
* 745f256ed1 Match IPv6 addresses as anonymous users
* e3d43db300 handle __NOGLOSSARY__ magicword
* d39e4577d3 Fixes #37  * In the case where MediaWiki is behind an Apache server that does the auth
Comment 8 Fedora Update System 2015-01-30 15:05:58 EST
python-mwlib-0.15.14-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-mwlib-0.15.14-1.fc21
Comment 9 Fedora Update System 2015-01-31 19:25:16 EST
Package python-mwlib-0.15.14-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-mwlib-0.15.14-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1492/python-mwlib-0.15.14-1.fc21
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2015-02-09 00:32:41 EST
python-mwlib-0.15.14-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.