Bug 1031288 - Can't create a livecd with generic-logos replacing fedora-logos
Can't create a livecd with generic-logos replacing fedora-logos
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: generic-logos (Show other bugs)
20
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 06:06 EST by M. Edward (Ed) Borasky
Modified: 2014-03-16 23:34 EDT (History)
5 users (show)

See Also:
Fixed In Version: generic-logos-17.0.0-5.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 21:44:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M. Edward (Ed) Borasky 2013-11-16 06:06:34 EST
Description of problem: I'm building a Fedora Remix Live ISO file using livecd-creator. Because it's a remix, I need to substitute generic logos for the Fedora branded ones. On Fedora 19, this all worked. But on Fedora 20, a new file, fedora-logos-httpd.noarch has appeared, and the dependency resolution step in the livecd-creator operation aborts with this message:

Transaction couldn't start:
file /usr/share/pixmaps/poweredby.png conflicts between attempted installs of fedora-logos-httpd-19.0.4-4.fc20.noarch and generic-logos-17.0.0-4.fc20.noarch
Error creating Live CD : Unable to install: Could not run transaction.




Version-Release number of selected component (if applicable):
Fedora 20

How reproducible:
You have to clone my Github repository (https://github.com/znmeb/CompJournoStick) and run the commands

$ cd CompJournoStick/2MakeLiveISOImage
$ sudo ./1SudoMakeISOImage.bash

although I imagine you could make a simpler test case by using any kickstart file that installed httpd and used the debranding options

-fedora-logos
-fedora-release
-fedora-release-notes
generic-logos
generic-release
generic-release-notes


Additional info:

This late in the Fedora 20 release cycle I don't necessarily expect a fix but I don't know the branded and generic packages well enough to figure out a workaround on my own. I assume there needs to be a 'generic-logos-httpd.noarch' package created. For my remix, I don't think I'm losing too much by staying with Fedora 19.
Comment 1 M. Edward (Ed) Borasky 2013-11-16 21:07:33 EST
I've got a little more info - fedora-logos-httpd is required by httpd according to rpm:

$ rpm -q --whatrequires fedora-logos-httpd
httpd-2.4.6-6.fc20.x86_64

I downloaded the source RPM and that's indeed the case, but I don't know what if anything will break if I remove the dependency on fedora-logos-httpd from httpd. Meanwhile, I can delete the packages that require httpd for a workaround.
Comment 2 Bill Nottingham 2013-11-18 10:22:32 EST
Argh. Joe - is it possible for this to be system-logos-httpd in the httpd requires?

If not, I can just provide that in generic-logos.
Comment 3 Joe Orton 2013-11-18 12:02:06 EST
Sure but we'd need that to be provided first.  fedora-logos provides system-logos but fedora-logos-httpd does not provide system-logos-httpd

[root@virt-f20c ~]# yum whatprovides system-logos-httpd
No matches found

(checking against fedora/20 and updates-testing/20 there)
Comment 4 Joe Orton 2013-11-18 12:03:47 EST
Actually... arguably the dependency on fedora-logos is technically correct because we want *Fedora* branding there.
Comment 5 Joe Orton 2013-11-18 12:04:46 EST
"dependency on fedora-logos-httpd" I mean there in comment 4, apologies for comment spam.
Comment 6 Bill Nottingham 2013-11-18 12:21:49 EST
It's a standing Fedora feature to be able to replace the branding with generic equivalents. I can certainly have something provide fedora-logos-httpd if needed.
Comment 7 M. Edward (Ed) Borasky 2013-11-18 13:09:19 EST
(In reply to Bill Nottingham from comment #6)
> It's a standing Fedora feature to be able to replace the branding with
> generic equivalents. I can certainly have something provide
> fedora-logos-httpd if needed.

I've done a bit of digging. It turns out

1. The source RPM for 'fedora-logos-httpd' is fedora-logos-19.0.4-4.fc20.src.rpm
2. The file that's causing the conflict lands in /usr/share/pixmaps/poweredby.png. It's a small image that reads 'Powered by Fedora'. For my remix I could live with a fully transparent image of the same size, but if there's something else that makes sense for 'generic-logos' on your end I can swap in my own PNG after the install. 

At some point I will need to make my own branded logos anyhow - the name "Generic" isn't the branding I want and there are still a few places where "Fedora" shows up, most notably on the screen that pops up on a GNOME Live CD - "Try Fedora" or "Install to Hard Drive".
Comment 8 Bill Nottingham 2013-11-18 14:23:55 EST
(In reply to M. Edward (Ed) Borasky from comment #7)
> (In reply to Bill Nottingham from comment #6)
> > It's a standing Fedora feature to be able to replace the branding with
> > generic equivalents. I can certainly have something provide
> > fedora-logos-httpd if needed.
> 
> I've done a bit of digging. It turns out
> 
> 1. The source RPM for 'fedora-logos-httpd' is
> fedora-logos-19.0.4-4.fc20.src.rpm
> 2. The file that's causing the conflict lands in
> /usr/share/pixmaps/poweredby.png. It's a small image that reads 'Powered by
> Fedora'. For my remix I could live with a fully transparent image of the
> same size, but if there's something else that makes sense for
> 'generic-logos' on your end I can swap in my own PNG after the install. 

Right, that one logo was split out from the main fedora-logos package into fedora-logos-httpd. It's still in the main generic-logos package.
Comment 9 Joe Orton 2013-11-18 15:40:16 EST
(In reply to Bill Nottingham from comment #6)
> It's a standing Fedora feature to be able to replace the branding with
> generic equivalents. I can certainly have something provide
> fedora-logos-httpd if needed.

My only point is that this Requires exists in the Fedora httpd package so as to bring in *the Fedora poweredby.png*.  That image has an ALT tag saying "Powered by Fedora" and the page is the Fedora test page.  To remove all user-visible traces of "Fedora" from the binary RPMs, you need to rebuild a modified version of the httpd source RPM, replacing that welcome page etc... and you can remove/change the dependency at that time.

If it's really required we can change the dep - but it is conceptually correct as-is, IMO.
Comment 10 Fedora Update System 2013-11-22 12:50:45 EST
generic-logos-17.0.0-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/generic-logos-17.0.0-5.fc20
Comment 11 Fedora Update System 2013-11-23 22:47:26 EST
Package generic-logos-17.0.0-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing generic-logos-17.0.0-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22010/generic-logos-17.0.0-5.fc20
then log in and leave karma (feedback).
Comment 12 M. Edward (Ed) Borasky 2013-11-24 23:14:48 EST
It's working now - will leave karma if I can log in - not sure I have an account on that server!
Comment 13 Bill Nottingham 2013-12-02 13:03:35 EST
It uses a standard fedora (FAS) account for login.
Comment 14 Fedora Update System 2013-12-13 21:44:00 EST
generic-logos-17.0.0-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.