Bug 1031299 - displays duplicate for each btrfs device with btrfs filesystem show
displays duplicate for each btrfs device with btrfs filesystem show
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: btrfs-progs (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 11:03 EST by Chris Murphy
Modified: 2013-12-13 21:44 EST (History)
8 users (show)

See Also:
Fixed In Version: btrfs-progs-3.12-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 21:44:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2013-11-16 11:03:37 EST
Description of problem: 

Duplicate results are produced when using btrfs filesystem show.


Version-Release number of selected component (if applicable):

btrfs-progs-0.20.rc1.20131114git9f0c53f-1.fc20.x86_64  


How reproducible:

Always


Steps to Reproduce:

1. Format a partition btrfs.
2. btrfs fi show

Actual results:

Label: fedora  uuid: 8acbdc01-bcda-4d0f-bc89-bb7414b9a11f
	Total devices 1 FS bytes used 33.95GiB
	devid    1 size 292.97GiB used 37.04GiB path /dev/sda6

Label: fedora  uuid: 8acbdc01-bcda-4d0f-bc89-bb7414b9a11f
	Total devices 1 FS bytes used 33.95GiB
	devid    1 size 292.97GiB used 37.04GiB path /dev/sda6

Expected results:

Just one of those results.


Additional info:

Does not occur with btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc20.x86_64.
Comment 1 Gene Czarcinski 2013-11-16 11:43:50 EST
And if you have a couple of multi-device btrfs volumes defined it gets really verbose with the repetition.  For example, a system with a two SSD btrfs volume and a two USB disk btrfs volume produced three outputs for the SSD volume and six for the USB disks volume.
Comment 2 Chris Murphy 2013-11-21 22:24:41 EST
Fix upstream available. http://www.mail-archive.com/linux-btrfs@vger.kernel.org/msg28960.html
Comment 3 Fedora Blocker Bugs Application 2013-11-21 22:29:42 EST
Proposed as a Freeze Exception for 20-final by Fedora user chrismurphy using the blocker tracking app because:

 This is a cosmetic bug, but it would be nice if F20 live media included a fix so that using live media to troubleshoot btrfs volumes is less cluttered than with the bug.
Comment 4 Chris Murphy 2013-11-26 15:21:53 EST
The (somewhat obscure) workaround is to use -d to avoid duplicates showing. And this bug is fixed in btrfs-progs 3.12. So I think the freezeexception is moot since there's unlikely to be an intermediate fix for release.
Comment 5 Eric Sandeen 2013-11-26 15:47:24 EST
Ah, whoops, I didn't add this bug to the 3.12 update.  Will do.
Comment 6 Fedora Update System 2013-11-26 15:53:34 EST
btrfs-progs-3.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-22152/btrfs-progs-3.12-1.fc20
Comment 7 Adam Williamson 2013-11-26 16:21:24 EST
so, dlehman and cmurf were both somewhat worried about changing btrfs-progs post-freeze when I asked about it in general terms. CCing dlehman: does your opinion change with this bug? or would you still prefer to stick with what we have in stable and in tc1/tc2 so far?
Comment 8 Chris Murphy 2013-11-26 16:40:17 EST
btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc20 = TC1/TC2

btrfs-progs-0.20.rc1.20131114git9f0c53f-1.fc20 = should be in TC3 as it went stable before freeze. The biggest change I can think of here is mkfs now uses 16KB leafsize/nodesize, but also causes this bug.

btrfs-progs 3.12 fixes this bug, but is intended for kernel 3.12 which isn't going to ship with F20.
Comment 9 Adam Williamson 2013-11-26 16:42:10 EST
ah, i didn't notice that we already have a new build for tc3, thanks for catching that. guess we'd best be on the lookout for issues.
Comment 10 Chris Murphy 2013-11-26 16:52:09 EST
FWIW, the leafsize/nodesize change doesn't cause this bug, I meant that this bug was introduced with the listed btrfs-progs version.

I've been using the 1114 progs with anaconda for almost 2 weeks with no apparent problems.
Comment 11 Eric Sandeen 2013-11-26 16:53:04 EST
FWIW, I don' care if this ships w/ F20 or not.  ;)  The release came out, I built it & pushed it - you all can decide what to do with it.  I won't complain either way.
Comment 12 David Lehman 2013-11-26 16:57:25 EST
I am fine with it going in as long as it doesn't change something that generates installer bugs, and I don't have time to verify that it doesn't break anything during OS installation.
Comment 13 Adam Williamson 2013-11-27 14:06:46 EST
Discussed at 2013-11-27 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-27/f20-blocker-review-3.2013-11-27-17.01.log.txt . This was rejected as a freeze exception issue, as the bug is cosmetic and not a huge problem, and can be fixed with a post-release update. It's not worth introducing change to a critical component for the installer just to fix this. If there's any more pressing reason to take 3.12 into GA, we can consider that, please nominate an appropriate bug as blocker/FE.
Comment 14 Fedora Update System 2013-12-13 21:44:41 EST
btrfs-progs-3.12-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.