Bug 1031306 - NPE being raised in the Sudoku example
NPE being raised in the Sudoku example
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
urgent Severity urgent
: ER6
: 6.0.0
Assigned To: Edson Tirelli
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 12:58 EST by Edson Tirelli
Modified: 2014-08-06 16:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edson Tirelli 2013-11-16 12:58:48 EST
A couple NPE are being raised by the Sudoku example when executing puzzles HARD 1 and HARD 4.
Comment 2 Edson Tirelli 2013-11-16 13:57:50 EST
The Sudoku example uncovered 3 very hard to reproduce bugs, but that are really critical for the core engine. 

These bugs are fixed, and due to the timing (weekend) and urgency of these fixes to be included in the release on Monday, I am committing the fixes without the 3-acks.

Commits:

(master)
http://github.com/droolsjbpm/drools/commit/4684c4aa9
http://github.com/droolsjbpm/drools/commit/cdc587d11

(6.0.x)
http://github.com/droolsjbpm/drools/commit/dc17703
http://github.com/droolsjbpm/drools/commit/08fd361
Comment 4 Edson Tirelli 2013-11-17 10:04:28 EST
One additional commit:

(master)
http://github.com/droolsjbpm/drools/commit/95e7e29d8

(6.0.x)
http://github.com/droolsjbpm/drools/commit/0a0a1a23b
Comment 5 Radovan Synek 2014-01-09 05:39:22 EST
Verified with BRMS-6.0.0.ER7 (no exception raises in Sudoku example).

Note You need to log in before you can comment on or make changes to this bug.