Bug 1031311 - Raspberry Pi, pidora: Error on yum upgrade
Raspberry Pi, pidora: Error on yum upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 13:40 EST by Axel Starck
Modified: 2014-04-19 23:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 03:25:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Starck 2013-11-16 13:40:46 EST
[root@kingyo ~]# yum upgrade
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package raspberrypi-kernel.armv6hl 0:3.6.11-7.20130415git197d15b.rpfr18 will be obsoleted
---> Package raspberrypi-kernel.armv6hl 0:3.6.11-12.20130920git966efc7.rpfr18 will be obsoleted
---> Package raspberrypi-kernel.armv6hl 0:3.11.6-3.20131023git10bc582.rpfr18 will be obsoleting
---> Package raspberrypi-kernel-headers.armv6hl 0:3.6.11-12.20130920git966efc7.rpfr18 will be updated
---> Package raspberrypi-kernel-headers.armv6hl 0:3.11.6-3.20131023git10bc582.rpfr18 will be an update
---> Package raspberrypi-vc-demo-source.armv6hl 0:20130918gitfadc4cb-2.rpfr18 will be updated
---> Package raspberrypi-vc-demo-source.armv6hl 0:20131018git4c14569-5.rpfr18 will be an update
---> Package raspberrypi-vc-firmware.armv6hl 0:20130918gitfadc4cb-2.rpfr18 will be updated
---> Package raspberrypi-vc-firmware.armv6hl 0:20131018git4c14569-5.rpfr18 will be an update
---> Package raspberrypi-vc-libs.armv6hl 0:20130918gitfadc4cb-2.rpfr18 will be updated
---> Package raspberrypi-vc-libs.armv6hl 0:20131018git4c14569-5.rpfr18 will be an update
---> Package raspberrypi-vc-libs-devel.armv6hl 0:20130918gitfadc4cb-2.rpfr18 will be updated
---> Package raspberrypi-vc-libs-devel.armv6hl 0:20131018git4c14569-5.rpfr18 will be an update
---> Package raspberrypi-vc-static.armv6hl 0:20130918gitfadc4cb-2.rpfr18 will be updated
---> Package raspberrypi-vc-static.armv6hl 0:20131018git4c14569-5.rpfr18 will be an update
---> Package raspberrypi-vc-utils.armv6hl 0:20130918gitfadc4cb-2.rpfr18 will be updated
---> Package raspberrypi-vc-utils.armv6hl 0:20131018git4c14569-5.rpfr18 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================
 Package                           Arch           Version                                   Repository                  Size
=============================================================================================================================
Installing:
 raspberrypi-kernel                armv6hl        3.11.6-3.20131023git10bc582.rpfr18        pidora-rpfr-updates         12 M
     replacing  raspberrypi-kernel.armv6hl 3.6.11-7.20130415git197d15b.rpfr18
     replacing  raspberrypi-kernel.armv6hl 3.6.11-12.20130920git966efc7.rpfr18
Updating:
 raspberrypi-kernel-headers        armv6hl        3.11.6-3.20131023git10bc582.rpfr18        pidora-rpfr-updates        779 k
 raspberrypi-vc-demo-source        armv6hl        20131018git4c14569-5.rpfr18               pidora-rpfr-updates         30 M
 raspberrypi-vc-firmware           armv6hl        20131018git4c14569-5.rpfr18               pidora-rpfr-updates        2.9 M
 raspberrypi-vc-libs               armv6hl        20131018git4c14569-5.rpfr18               pidora-rpfr-updates        218 k
 raspberrypi-vc-libs-devel         armv6hl        20131018git4c14569-5.rpfr18               pidora-rpfr-updates        235 k
 raspberrypi-vc-static             armv6hl        20131018git4c14569-5.rpfr18               pidora-rpfr-updates        152 k
 raspberrypi-vc-utils              armv6hl        20131018git4c14569-5.rpfr18               pidora-rpfr-updates        115 k


Transaction Summary
=============================================================================================================================
Install  1 Package
Upgrade  7 Packages

Total size: 47 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
raspberrypi-kernel < 3.11.6 is obsoleted by raspberrypi-kernel-3.11.6-3.20131023git10bc582.rpfr18.armv6hl
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
lightdm-1.4.0-2.fc18.armv6hl has missing requires of lightdm-gobject(armv6hl-32) = ('0', '1.4.0', '2.fc18')
lightdm-1.4.1-3.fc18.1307170533kf.armv6hl is a duplicate with lightdm-1.4.0-2.fc18.armv6hl
mdadm-3.2.6-21.fc18.armv6hl is a duplicate with mdadm-3.2.6-1.fc18.armv6hl
openssh-server-6.1p1-6.fc18.armv6hl has missing requires of openssh = ('0', '6.1p1', '6.fc18')
openssh-server-6.1p1-9.fc18.armv6hl is a duplicate with openssh-server-6.1p1-6.fc18.armv6hl
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2013-11-13.20-22.gBT0rK.yumtx

[root@kingyo ~]# more /etc/issue
Pidora release 18 (Raspberry Pi Fedora Remix)
Kernel \r on an \m (\l)

[root@kingyo ~]# more /proc/version
Linux version 3.6.11 (mockbuild@) (gcc version 4.7.2 20120921 (Red Hat 4.7.2-2) (GCC) ) #1 PREEMPT Wed Oct 2 16:19:09 EDT
 2013

[root@kingyo ~]# more /proc/cpuinfo 
Processor	: ARMv6-compatible processor rev 7 (v6l)
BogoMIPS	: 697.95
Features	: swp half thumb fastmult vfp edsp java tls 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xb76
CPU revision	: 7

Hardware	: BCM2708
Revision	: 000e
Serial		: 0000000039f13163
Comment 1 Jan Zeleny 2013-11-18 03:25:27 EST
I'm sorry, but this is not a bug. Yum just reports that your system is in inconsistent state and therefore nothing can be done with it automatically. Try to manually resolve the pre-existing problems detected in rpmdb, that should make yum work again.
Comment 2 mov_ebpesp 2013-12-08 15:19:02 EST
I have exactly the same problem after a yum update.

openssh-server, lightdm, midadm 'has missing requires' and the kernel with 'obsolete'.


No amount of rpm -ehv or yum erase seems to fix this.

I think there is an error in the requires configuration for these rpm packages that brings the system in an inconsistent state.
Comment 3 mov_ebpesp 2013-12-08 19:23:08 EST
For posterity, in case someone stumbles on this from google:

The most important side effect of this is SSH not working after the update which is probably what most people will be interested in fixing.

To fix the rpm parts:
# rpm -ehv --noscripts openssh-server lightdm midadm kernel-raspberrypi-kernel-YOUR.VERSION.HERE
# yum install openssh-server

To fix the ssh connectivity:
# yum remove firewalld

To enable permanent iptables settings:
# ln -s /usr/lib/systemd/system/iptables.service /etc/systemd/network.target.wants/iptables.service
# vi /etc/sysconfig/iptables-config
Enable all the IPTABLES_SAVE things by saying "yes".
# system-config-firewall-tui
Follow the nice interface and choose Customize. At the long list of services choose "ssh" (should be like this by default). At last step Close and Ok. After it commits, just Cancel out.
# systemctl restart iptables
# reboot
Confirm 'iptables -L' returns correct firewall settings.

Background: there is a bug in firewalld that prevents it working with kernels that don't have NAT iptables support compiled in. Which is the case with the one I'm running (raspberrypi-kernel-3.12.0-4). The firewalld bug is fixed in a later version included in FC20.

Note You need to log in before you can comment on or make changes to this bug.