Bug 1031323 - instance resource names are limited to 63 characters
instance resource names are limited to 63 characters
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
4.0
x86_64 Linux
high Severity high
: rc
: 4.0
Assigned To: Steven Dake
Steven Dake
: OtherQA, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 15:33 EST by Steven Dake
Modified: 2016-04-26 16:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-heat-2013.2-2.0.el6ost
Doc Type: Bug Fix
Doc Text:
The resource name limit of Compute instances is 63 characters. However, it was possible for the Orchestration service to create resource names with more characters. Whenever this occurred, Compute instances could not obtain DHCP addresses. This release adds a truncation logic to the Orchestration service's resource name generation. The added logic limits Orchestration resource names to 63 characters while also ensuring that each name is secure and unique.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:36:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1250291 None None None Never
OpenStack gerrit 16909 None None None Never
OpenStack gerrit 56828 None None None Never

  None (edit)
Description Steven Dake 2013-11-16 15:33:03 EST
Description of problem:
During the final days of heat development, we found that instance names were limited to 63 characters.  We have found through lots of upstream support requests, that this doesn't work for many people's use cases.  I believe our customers would be negatively impacted if they see this limit.

Version-Release number of selected component (if applicable):
openstack-heat-2013.1.4-1.el6

How reproducible:
100%

Steps to Reproduce:
1. create a template with a instance resource name of greater then 63 characters
2.
3.

Actual results:
Heat generates an error to the user that the template has a resource name that is too long

Expected results:
Heat should work with any resource name length

Additional info:
Comment 2 Steven Dake 2013-11-16 15:36:06 EST
@sbaker,

You did the work on the upstream patch.  I seem to recall from IRC that you were planning on handling backports for Havana.  If this is not the case, could you assign the cherry-pick to someone else?  I believe Steve Hardy also has experience in this area.

Once the bug is merged into stable/havana upstream, set needinfo on me, and I'll do a build with the changes.
Comment 3 Steven Dake 2013-11-16 15:46:28 EST
Version number is wrong in Comment #0.  It should be:
openstack-heat-2013.2-1.0.el6
Comment 4 Eoghan Glynn 2013-12-05 10:59:42 EST
Backport proposed internally:

  https://code.engineering.redhat.com/gerrit/16909

in parallel with the review on stable/havana upstream:

  https://review.openstack.org/56828

(to avoid any delays in it landing upstream blocking the fix getting into the RC).
Comment 9 errata-xmlrpc 2013-12-19 19:36:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.