Bug 1031328 - Gluster man pages are out of date.
Gluster man pages are out of date.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
pre-release
All All
medium Severity medium
: ---
: ---
Assigned To: Harshavardhana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 16:32 EST by Kurt Seifried
Modified: 2015-03-22 21:04 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-11 03:24:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Seifried 2013-11-16 16:32:37 EST
Description of problem:

The man pages are out of date and missing a significant portion of the newer features.

For example mount.glusterfs is fails to cover the following options:

* backupvolfile-server=server name - name of the backup volfile server to mount the client. If this option is added while mounting fuse client, when the first volfile server fails, then the server specified in backupvolfile-server option is used as volfile server to mount the client.
* fetch-attempts=number - number of attempts to fetch volume files while mounting a volume. This option is useful when you mount a server with multiple IP addresses or when round-robin DNS is configured for the server name.
* acl - enables POSIX Access Control List on mount.
* selinux - enables handling of SELinux xattrs through the mount point.
* background-qlen=length - this option enables FUSE to handle n number of requests to be queued before stopping to accept new requests. Default value of n is 64.
* enable-ino32 - this option enables file system to present 32-bit inodes instead of 64- bit inodes.

This is covered in the online docs for example at:

https://access.redhat.com/site/documentation/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/chap-Administration_Guide-GlusterFS_Client.html

We really need correct man pages!
Comment 1 Kurt Seifried 2013-11-16 16:34:19 EST
Also it would be good if there are descriptions for what things like "direct-io-mode=[enable|disable]" actually do.
Comment 2 Harshavardhana 2013-11-22 04:34:08 EST
http://review.gluster.com/#/c/5931/ - RFC patch available please review - this also updates the man pages
Comment 3 Justin Clift 2014-02-15 12:39:01 EST
Looking over the patch by Harshavardhana, it's missing:

 * fetch-attempts
 * background-qlen
 * enable-ino32
 * direct-io-mode
Comment 4 Harshavardhana 2014-02-16 02:22:37 EST
(In reply to Justin Clift from comment #3)
> Looking over the patch by Harshavardhana, it's missing:
> 
>  * fetch-attempts
>  * background-qlen
>  * enable-ino32
>  * direct-io-mode

Can you send a patch?
Comment 5 Justin Clift 2014-02-16 09:26:49 EST
Unfortunately, not in the near future. :(
Comment 6 Anand Avati 2014-03-25 21:49:19 EDT
REVIEW: http://review.gluster.org/7338 (doc: Update manpages) posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 7 Anand Avati 2014-03-26 16:13:22 EDT
REVIEW: http://review.gluster.org/7338 (doc: Update manpages) posted (#2) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 8 Anand Avati 2014-03-28 13:26:55 EDT
COMMIT: http://review.gluster.org/7338 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 7c36d9ec0de67b9b9a0803fcd378ef8d3b453c87
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Tue Mar 25 10:13:35 2014 -0700

    doc: Update manpages
    
    Change-Id: Id14c7c3229ed266cd15915a2136e3290ce2c5ed2
    BUG: 1031328
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/7338
    Reviewed-by: Lalatendu Mohanty <lmohanty@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>
Comment 9 Anand Avati 2014-09-08 14:14:26 EDT
REVIEW: http://review.gluster.org/8656 (doc: Remove volume rename from gluster's man page.) posted (#1) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 10 Anand Avati 2014-09-08 23:33:59 EDT
REVIEW: http://review.gluster.org/8656 (doc: Remove volume rename from gluster's man page.) posted (#2) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)
Comment 11 Anand Avati 2014-09-09 09:30:07 EDT
COMMIT: http://review.gluster.org/8656 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit c2513927b3aeaf03e0cfe1c1869c43f2a8f84153
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Mon Sep 8 23:33:00 2014 +0530

    doc: Remove volume rename from gluster's man page.
    
    Change-Id: I5cde789088417f26d0c8319a1b24fdaa2c37dfe6
    BUG:  1031328
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/8656
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 12 Niels de Vos 2014-09-22 08:32:47 EDT
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 13 Niels de Vos 2014-11-11 03:24:40 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users

Note You need to log in before you can comment on or make changes to this bug.