Bug 1031345 - openlmi-software: detect nevra with ~ (tilde) in version
openlmi-software: detect nevra with ~ (tilde) in version
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openlmi-providers (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Minar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1043161
  Show dependency treegraph
 
Reported: 2013-11-16 22:03 EST by Klaus Kämpf
Modified: 2014-05-29 03:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: openlmi-providers-0.4.2-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1043161 (view as bug list)
Environment:
Last Closed: 2014-05-29 03:39:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add tilde to allowed characters of package version (1.55 KB, patch)
2013-11-16 22:03 EST, Klaus Kämpf
no flags Details | Diff

  None (edit)
Description Klaus Kämpf 2013-11-16 22:03:28 EST
Created attachment 825034 [details]
add tilde to allowed characters of package version

Description of problem:
openSUSE package versions may contain ~ (tilde), like

libphonon4-0:4.6.80~git20130930-1.1.x86_64
phonon-backend-gstreamer-0_10-4.6.80~git20130915-2.1.4.x86_64

the regular expressions of openlmi-software fail to match this.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michal Minar 2013-11-18 01:44:03 EST
Thanks Klaus, I'll post it on review.

Note You need to log in before you can comment on or make changes to this bug.