Bug 1031359 - Messages set to be encrypted were sent unencrypted after a crash.
Messages set to be encrypted were sent unencrypted after a crash.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-17 02:49 EST by Björn Persson
Modified: 2013-11-20 06:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 06:53:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 712738 None None None Never

  None (edit)
Description Björn Persson 2013-11-17 02:49:42 EST
Description of problem:
I had prepared a number of messages that were to be signed and encrypted. While I was sending them bug 1031358 happened. I restarted Evolution and it restored the unsent messages, so I continued sending them. Later I found out that those that had been sent after the crash had not been encrypted. Apparently the setting to encrypt wasn't included in what was restored.

Version-Release number of selected component (if applicable):
evolution-3.8.5-2.fc19
Comment 1 Milan Crha 2013-11-20 06:53:07 EST
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

I can reproduce it too, with current development version, thus it's still there.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=712738

Note You need to log in before you can comment on or make changes to this bug.