Bug 1031363 - [abrt] yum-3.4.3-106.fc20: misc.py:952:unlink_f:OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/20/fedora/gen/primary_db.sqlite'
[abrt] yum-3.4.3-106.fc20: misc.py:952:unlink_f:OSError: [Errno 13] Permissio...
Status: CLOSED DUPLICATE of bug 975619
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:3c4011f52903f9ae3982fe3312c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-17 04:04 EST by collura
Modified: 2013-11-18 03:46 EST (History)
6 users (show)

See Also:
Fixed In Version: yum-3.4.3-111.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 03:46:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.59 KB, text/plain)
2013-11-17 04:04 EST, collura
no flags Details

  None (edit)
Description collura 2013-11-17 04:04:00 EST
Version-Release number of selected component:
yum-3.4.3-106.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available perf
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.10.4-300.fc19.x86_64
runlevel:       N 5
type:           Python

Truncated backtrace:
misc.py:952:unlink_f:OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/20/fedora/gen/primary_db.sqlite'

Traceback (most recent call last):
  File "/usr/share/yum-cli/completion-helper.py", line 95, in <module>
    main(sys.argv[1:])
  File "/usr/share/yum-cli/completion-helper.py", line 88, in main
    base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 532, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/completion-helper.py", line 52, in doCommand
    patterns=[get_pattern(extcmds)])
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2910, in doPackageLists
    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1050, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 770, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 383, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 237, in populate
    misc.unlink_f(repo.cachedir +'/gen/%s.sqlite' % mydbtype)
  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 952, in unlink_f
    os.unlink(filename)
OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/20/fedora/gen/primary_db.sqlite'

Local variables in innermost frame:
e: OSError(13, 'Permission denied')
filename: '/var/cache/yum/x86_64/20/fedora/gen/primary_db.sqlite'
Comment 1 collura 2013-11-17 04:04:09 EST
Created attachment 825103 [details]
File: backtrace
Comment 2 Zdeněk Pavlas 2013-11-18 03:46:19 EST
Fixed in -111.

*** This bug has been marked as a duplicate of bug 975619 ***

Note You need to log in before you can comment on or make changes to this bug.