Bug 1031366 - Incorrect error message when trying to import network with invalid name from network provider
Incorrect error message when trying to import network with invalid name from ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Linux
medium Severity high
: ---
: 3.3.0
Assigned To: Lior Vernia
Meni Yakove
network
:
Depends On:
Blocks: 3.3rc1
  Show dependency treegraph
 
Reported: 2013-11-17 05:09 EST by awinter
Modified: 2016-02-10 14:50 EST (History)
9 users (show)

See Also:
Fixed In Version: is27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt-engine's log (302.42 KB, text/x-log)
2013-11-17 05:12 EST, awinter
no flags Details
A video that shows the problem (113.33 KB, video/x-theora+ogg)
2013-11-17 05:15 EST, awinter
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22035 None None None Never

  None (edit)
Description awinter 2013-11-17 05:09:48 EST
Description of problem:
After creating a network in Neutron with the name "net_created_in_neutron" I tried to import it to rhevm.
The import failed with the error:
"Error while executing action: User is not authorized to perform this action."

The problem is that the name of the network is too long for rhevm (max length is 15).

ovirt report in its log that the name is illegal, pop a window in GUI but then it tries to create vNicProfile and fails. The failure of the creation of the profile also sends a pop up window instead of the existing one and the user gets the wrong error output.

How reproducible:
100%

Steps to Reproduce:
1. create a network in neutron with a long name "net_created_in_neutron"
2. try to import the network without changing its name

Actual results:
An error message appears:
"Error while executing action: User is not authorized to perform this action."

Expected results:
The error message should be:
"Invalid name, max length is 15" (Or something like that... )

Additional info:
We should also check that the only legal characters are a-z, A-Z, 0-9 and "_"
Comment 1 awinter 2013-11-17 05:12:24 EST
Created attachment 825115 [details]
ovirt-engine's log
Comment 2 awinter 2013-11-17 05:15:05 EST
Created attachment 825116 [details]
A video that shows the problem
Comment 3 awinter 2013-11-17 05:42:47 EST
I now saw that the same thing is happening when trying to import a network with vlan that already exists in the DC.

Steps to Reproduce:
1. Create a network via rhevm GUI with vlan 163
2. Create a network via Neutron with vlan 163
3. Import the network

Actual results:
An error message appears:
"Error while executing action: User is not authorized to perform this action."

Expected results:
The error message should be:
"Error while executing action: The specified VLAN ID (163) is already in use."
Comment 6 Meni Yakove 2013-12-15 08:51:27 EST
rhevm-3.3.0-0.40.rc.el6ev.noarch
Comment 7 Itamar Heim 2014-01-21 17:20:41 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:26:19 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.