Bug 1031383 - anacron segfaults with certain config data
Summary: anacron segfaults with certain config data
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: Robin Hack
URL:
Whiteboard:
: 1189361 (view as bug list)
Depends On:
Blocks: 1075802 1031384
TreeView+ depends on / blocked
 
Reported: 2013-11-17 14:05 UTC by Martin Poole
Modified: 2019-04-16 14:06 UTC (History)
5 users (show)

Fixed In Version: cronie-1.4.4-14.el6
Doc Type: Bug Fix
Doc Text:
Cause: The format of configuration settings in anacrontab were not properly checked in some cases. Consequence: This could cause a crash of the anacron process if such incorrect configuration settings were present in the anacrontab file. Fix: The format of the configuration settings in anacrontab is now checked properly. Result: The anacron does not crash any more with such configuration.
Clone Of:
: 1031384 (view as bug list)
Environment:
Last Closed: 2015-03-19 12:31:39 UTC


Attachments (Terms of Use)
patch to correctly check match_rx return codes (1.51 KB, patch)
2013-11-17 14:05 UTC, Martin Poole
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0704 normal SHIPPED_LIVE cronie bug fix and enhancement update 2015-03-19 16:26:29 UTC

Description Martin Poole 2013-11-17 14:05:38 UTC
Created attachment 825147 [details]
patch to correctly check match_rx return codes

Description of problem:

anacron does not correctly check configuration parameters for validity and can segfault on certain data types

The return code from the match_rx calls in readtab.c are not being checked correctly, 

Version-Release number of selected component (if applicable):

cronie-1.4.4-10.el6

How reproducible:

Always

Steps to Reproduce:
1. Set  START_HOURS_RANGE=0

Actual results:

Segmentation fault


Additional info:

There is also a possible divide-by-zero segfault if RANDOM_DELAY=0.

Comment 2 Tomas Mraz 2015-02-05 13:41:57 UTC
*** Bug 1189361 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2015-03-19 12:31:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0704.html


Note You need to log in before you can comment on or make changes to this bug.