Bug 103146 - (NET 3C59X) Very slow FTP's
(NET 3C59X) Very slow FTP's
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: 103278
  Show dependency treegraph
 
Reported: 2003-08-26 22:42 EDT by Mahesh Tailor
Modified: 2013-07-02 22:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:34:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mahesh Tailor 2003-08-26 22:42:33 EDT
Description of problem:

Using taroon-beta2. . .

Tranferring files from another UNIX server (does not matter; tried AIX,
RedhatAS, Redhat9) is really slow.  Checked the network setting on both ends
using mii-tool and is reported and set correctly (100BaseTx-FD).  Cabling has
been changed.

Had this problem with Redhat9 [and after some searching found] and added the
following to /etc/rc.d/init.d/autofs which resolved the problem:
localoptions='rsize=8192,wsize=8192'.  

Tried the same on taroon-beta2, no luck; I get 100KB/s-180KB/s for any file
greater than 1MB.  

Disconnected the machine from the network and connected another machine with the
same connect running Redhat9 with the localoptions set and getting
700KB/s-957KB/s consistantly.

Removed the HD from taroon-beta2 machine and installed another drive [same
model] running Redhat9 with localoptions set and getting 700KB/s-957KB/s
consistantly; thus eliminating hardware [Dell Optiplex 240] and network as the
possible suspects.

Actual results:

autofs:
  localoptions=''                                    100KB/s-180KB/s
  localoptions='rsize=8192,wsize=8192'               167KB/s-247KB/s
  localoptions='rsize=4096,wsize=4096'               167KB/s-247KB/s
  localoptions='rsize=1024,wsize=1024'               120KB/s-187KB/s
  localoptions='nfsvers=2,rsize=8192,wsize=8192'     167KB/s-247KB/s
  localoptions='rsize=8192,wsize=8192,async'         120KB/s-187KB/s

Expected results:

700KB/s to >900KB/s

Additional information:

Cisco switch is not reporting any errors which would indicate a negotiation problem.
Comment 1 Bill Nottingham 2003-08-26 23:32:24 EDT
What network driver?
Comment 2 Mahesh Tailor 2003-08-27 09:12:59 EDT
The driver is 3c59x.
Comment 3 Uwe Beck 2003-08-27 18:14:16 EDT
In Bug 102685 I reported such a problem with the NET 3C59X (3c905B, 3c905
cards). My example shows a very slow FTP. But I see with mii-tool a
autonegotiations problem on a 10 MB HUB. Now I have install
kernel-2.4.21-1.1931.2.411.ent from RHN, the problem is the same.
On Tarron-beta2 CDs there are kernel-2.4.21-1.1931.2.399.ent.
Comment 4 Mahesh Tailor 2003-08-27 23:15:38 EDT
This machine is connected to a Cisco switch and we are not seeing any errors on 
the port; errors that we'd see if there was a autonegotiation problem.  

Both kernel-2.4.21-1.1931.2.399.ent and kernel-2.4.21-1.1931.2.411.ent behave 
this way.
Comment 5 RHEL Product and Program Management 2007-10-19 15:34:56 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.