Bug 1031460 - a shutdown guest using glusterfs volume can't do snapshot
a shutdown guest using glusterfs volume can't do snapshot
Status: CLOSED DUPLICATE of bug 1032370
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Krempa
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-17 22:14 EST by Shanzhi Yu
Modified: 2013-11-22 09:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 09:10:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shanzhi Yu 2013-11-17 22:14:02 EST
Description of problem:

a shutdown guest using glusterfs volume  can't do snapshot 

Version-Release number of selected component (if applicable):

libvirt-1.1.1-12.el7.x86_64
qemu-kvm-rhev-1.5.3-19.el7.x86_64

How reproducible:

100%

Steps to Reproduce:

1. create an guest using glusterfs volume as source disk
# virsh dumpxml rhel6 
..
<disk type='network' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source protocol='gluster' name='gluster-vol1/rhel6-qcow2.img'>
        <host name='10.66.106.22' port='24007' transport='rdma'/>
      </source>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </disk>
    <controller type='scsi' index='0' model='virtio-scsi'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
    </controller>

..

2. do snapshot when guest is shutdown status
# virsh list --all;virsh snapshot-create rhel6
 Id    Name                           State
----------------------------------------------------
 -   rhel6                            shut off 

error: internal error: Child process (/usr/bin/qemu-img snapshot -c 1384506501 gluster-vol1/rhel6-qcow2.img) unexpected exit status 1: qemu-img: Could not open 'gluster-vol1/rhel6-qcow2.img': Could not open file: No such file or directory



3. do snapshot when guest is running

# virsh list;virsh snapshot-create rhel6
 Id    Name                           State
----------------------------------------------------
 52    rhel6                          running

Domain snapshot 1384506518 created

Actual results:

as above

Expected results:

can do snapshot when guest is shut down

Additional info:
Comment 2 Peter Krempa 2013-11-22 09:10:00 EST

*** This bug has been marked as a duplicate of bug 1032370 ***

Note You need to log in before you can comment on or make changes to this bug.