Bug 1031507 - Error in PREUN scriptlet in rpm package usbmuxd-1.0.8-10.fc20.i686
Error in PREUN scriptlet in rpm package usbmuxd-1.0.8-10.fc20.i686
Status: CLOSED DUPLICATE of bug 1017493
Product: Fedora
Classification: Fedora
Component: usbmuxd (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 02:25 EST by Mikhail
Modified: 2013-11-18 04:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 04:59:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2013-11-18 02:25:27 EST
Description of problem:

[root@ws166 ~]# yum check
Loaded plugins: langpacks, refresh-packagekit
usbmuxd-1.0.8-9.fc20.i686 is a duplicate with usbmuxd-1.0.8-8.fc20.i686
usbmuxd-1.0.8-10.fc20.i686 is a duplicate with usbmuxd-1.0.8-9.fc20.i686
Error: check all
[root@ws166 ~]# yum reinstall usbmuxd
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package usbmuxd.i686 0:1.0.8-10.fc20 will be an update
---> Package usbmuxd.i686 0:1.0.8-10.fc20 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================
 Package                              Arch                              Version                                    Repository                            Size
==============================================================================================================================================================
Updating:
 usbmuxd                              i686                              1.0.8-10.fc20                              fedora                                69 k
Removing:
 usbmuxd                              i686                              1.0.8-10.fc20                              @fedora                              178 k
Not available:
 usbmuxd                              i686                              1.0.8-9.fc20                               -                                    0.0  
 usbmuxd                              i686                              1.0.8-8.fc20                               -                                    0.0  

Transaction Summary
==============================================================================================================================================================
Upgrade        1 Package
Remove         1 Package
Not available  2 Packages

Total download size: 69 k
Is this ok [y/d/N]: y
Downloading packages:
Not downloading Presto metadata for fedora
usbmuxd-1.0.8-10.fc20.i686.rpm                                                                                                         |  69 kB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : usbmuxd-1.0.8-10.fc20.i686                                                                                                                 1/4 
/var/tmp/rpm-tmp.SzbhXq: line 1: fg: no job control
error: %preun(usbmuxd-1.0.8-9.fc20.i686) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package usbmuxd-1.0.8-10.fc20.i686
error: usbmuxd-1.0.8-9.fc20.i686: erase failed
/var/tmp/rpm-tmp.1aCamc: line 1: fg: no job control
/var/tmp/rpm-tmp.1aCamc: line 3: fg: no job control
/var/tmp/rpm-tmp.1aCamc: line 5: fg: no job control
error: %preun(usbmuxd-1.0.8-8.fc20.i686) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package usbmuxd
  Verifying  : usbmuxd-1.0.8-10.fc20.i686                                                                                                                 1/1 
  Verifying  : usbmuxd-1.0.8-10.fc20.i686                                                                                                                 2/1 

Updated:
  usbmuxd.i686 0:1.0.8-10.fc20                                                                                                                                

Failed:
  usbmuxd.i686 0:1.0.8-10.fc20                                                                                                                                

Complete!
Comment 1 Jan Zeleny 2013-11-18 03:32:20 EST
Not a bug in yum, reassigning to usbmuxd.
Comment 2 Peter Robinson 2013-11-18 04:59:49 EST
The scripts in the old version are broken, which is what the updated version fixes. The broken scripts from the buggy package get executed upon its removal, preventing it from getting cleanly erased. 'rpm -e --noscripts usbmuxd-1.0.8-8.fc20.i686' to get rid of the buggy version.

*** This bug has been marked as a duplicate of bug 1017493 ***

Note You need to log in before you can comment on or make changes to this bug.