Bug 1031552 - fail to install windows guest with virtio-win driver from floppy
fail to install windows guest with virtio-win driver from floppy
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 04:42 EST by Sibiao Luo
Modified: 2013-12-04 11:38 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 11:38:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-11-18 04:42:06 EST
Description of problem:
fail to install windows guest with virtio-win driver (virtio-win-1.6.7-2.el7.noarch) from floppy. Also tried with the virtio-win-1.6.7-2.el6.noarch in rhe7 host that still hit it.
btw, rhel6.5 host did not hit such issue.

Version-Release number of selected component (if applicable):
host info:
3.10.0-41.el7.x86_64
qemu-kvm-1.5.3-19.el7.x86_64
seabios-1.7.2.2-4.el7.x86_64
guest info:
win7 64bit
virtio-win-1.6.7-2.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.install virtio-win in host and download win7 iso.
2.install guest vir iso with virtio-win driver from floppy.
e.g:...-drive file=/home/sluo-test1.qcow2,if=none,id=drive-virtio-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,vectors=0,bus=pci.0,addr=0x4,scsi=off,drive=drive-virtio-disk,id=virtio-disk,bootindex=1 -drive file=/home/en_windows_7_ultimate_with_sp1_x86_dvd_619077.iso,if=none,id=drive-data-disk,media=cdrom,format=raw,cache=none,werror=stop,rerror=stop -device ide-drive,bus=ide.0,unit=0,drive=drive-data-disk,id=data-disk,bootindex=0 -fda /usr/share/virtio-win/virtio-win-1.6.7_amd64.vfd
3.

Actual results:
fail to detect the virtio-win driver after select load it from floppy.

Expected results:
it can install windows guest with virito-win driver from floppy successfully.

Additional info:
Comment 2 Yan Vugenfirer 2013-11-18 12:08:30 EST
Hi,

Please provide full command line. Can be related to BZ#894956 


Best regards,
Yan.
Comment 3 Sibiao Luo 2013-11-18 21:33:20 EST
(In reply to Yan Vugenfirer from comment #2)
> Hi,
> 
> Please provide full command line. Can be related to BZ#894956 
> 
I think not relate to it, I did not use the Q35, just use the pc machine type.

# /usr/libexec/qemu-kvm -M pc -S -cpu host -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -no-kvm-pit-reinjection -usb -device usb-tablet,id=input0 -name sluo -uuid 990ea161-6b67-47b2-b803-19fb01d30d30 -rtc base=localtime,clock=host,driftfix=slew -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=0,bus=pci.0,addr=0x3 -chardev socket,id=channel1,path=/tmp/helloworld1,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port1 -chardev socket,id=channel2,path=/tmp/helloworld2,server,nowait -device virtserialport,chardev=channel2,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port2 -drive file=/home/sluo-test1.qcow2,if=none,id=drive-virtio-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,vectors=0,bus=pci.0,addr=0x4,scsi=off,drive=drive-virtio-disk,id=virtio-disk,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=00:01:02:B6:40:21,bus=pci.0,addr=0x5 -device virtio-balloon-pci,id=ballooning,bus=pci.0,addr=0x6 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -drive file=/home/en_windows_7_ultimate_with_sp1_x86_dvd_619077.iso,if=none,id=drive-data-disk,media=cdrom,format=raw,cache=none,werror=stop,rerror=stop -device ide-drive,bus=ide.0,unit=0,drive=drive-data-disk,id=data-disk,bootindex=0 -fda /usr/share/virtio-win/virtio-win-1.6.7_amd64.vfd -k en-us -boot menu=on -vnc :1 -spice disable-ticketing,port=5931 -monitor stdio

Best Regards,
sluo
Comment 5 Yan Vugenfirer 2013-11-19 03:54:44 EST
Thanks!
Comment 6 Ronen Hod 2013-11-20 12:34:04 EST
Pay attention to https://bugzilla.redhat.com/show_bug.cgi?id=1032222#c14
Comment 7 Yan Vugenfirer 2013-11-21 04:57:38 EST
Check comment #6
Comment 8 Sibiao Luo 2013-11-26 00:38:18 EST
(In reply to Yan Vugenfirer from comment #7)
> Check comment #6
I don't think this bug 1032222 was related to this one, as the virtio-win whql driver has problem that not support Win2012R2 in bug 1032222, but this bug is  about just the QEMU not the whql, you can check the comment#0 which the same whql driver in rhel6.5 host has no any problem.

Best Regards,
sluo
Comment 9 Mike Cao 2013-12-04 01:23:34 EST
Reproduced this issue over win7-32 guests w/ virtio-win-1.6.7-2.el7 on 
Set testblocker flag
Comment 10 Mike Cao 2013-12-04 01:30:45 EST
(In reply to Mike Cao from comment #9)
> Reproduced this issue over win7-32 guests w/ virtio-win-1.6.7-2.el7 on 
> Set testblocker flag

The driver can not be loaded from ISO as well , raising the prioty

CLI:]# /usr/libexec/qemu-kvm -M pc-i440fx-rhel7.0.0 -cpu SandyBridge -enable-kvm -m 2G -smp 2,cores=2 -name bcao_win-7-32-netkvm -uuid 884e673a-1b4a-4385-a522-b3cc35ef4e18 -rtc base=localtime,clock=host,driftfix=slew -drive file=win7-32_2.qcow2,if=none,media=disk,serial=aaabbbccc,werror=stop,rerror=stop,cache=none,format=qcow2,id=drive-disk0 -device virtio-blk-pci,physical_block_size=4096,logical_block_size=512,drive=drive-disk0,id=disk0 -drive file=en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso,if=none,media=cdrom,id=aa -device ide-drive,id=aa1,drive=aa,bootindex=1 -drive file=/usr/share/virtio-win/virtio-win.iso,media=cdrom,if=none,id=bb -device ide-drive,id=bb1,drive=bb  -netdev tap,vhost=on,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=nic1,mq=off,mac=1a:46:0b:ca:bc:7b -spice port=5931,disable-ticketing -vga qxl -monitor stdio -usb -device usb-tablet,id=tablet0 -global PIIX4_PM.disable_s3=0 -global PIIX_PM.disable_s4=0 -monitor unix:/tmp/tt,server,nowait -drive file=test.img,format=raw,id=drive-test,if=none,werror=stop,rerror=stop -device virtio-blk-pci,physical_block_size=4096,logical_block_size=4096,id=test,drive=drive-test
Comment 12 lijin 2013-12-04 02:33:51 EST
win8-64 cannot reproduce this issue with virtio-1.6.7-2,guest can load driver from floopy and finish the installation.    
package info:
    virtio-win-1.6.7-2.el7.noarch
    kernel-3.10.0-53.el7.x86_64
    qemu-kvm-rhev-1.5.3-19.el7.x86_64
    seabios-1.7.2.2-4.el7.x86_64
Comment 15 Yan Vugenfirer 2013-12-04 11:38:42 EST
Closing according to comment #12 and comment #13

Note You need to log in before you can comment on or make changes to this bug.