Bug 1031554 - Undelivered messages
Undelivered messages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pidgin-sipe (Show other bugs)
20
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Stefan Becker
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 04:44 EST by Artur Cuvasov
Modified: 2014-06-16 07:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: pidgin-sipe-1.17.3-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-20 21:20:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artur Cuvasov 2013-11-18 04:44:04 EST
Description of problem:
After upgrading the plugin I have got problems with delivering messages. After logging in I am able to start a chat a send several messages and receive replies. After that I am not able to send anything anymore, getting the "This message was not delivered to 'name' because the service is not available" error. In the meantime I am still able to receive messages from a person, and the status is online. Able to eliminate it by going offline and back online, however not for long - the problem repeats again.

Version-Release number of selected component (if applicable):
Name        : pidgin-sipe
Version     : 1.17.1
Release     : 1.fc20
Architecture: i686
Comment 1 Stefan Becker 2013-11-18 06:12:10 EST
Please attach a --debug log.

BTW: from what version did you upgrade? The changes from 1.17.0 to 1.17.1 are benign and don't have anything to do with message sending.
Comment 2 Artur Cuvasov 2013-11-18 06:18:24 EST
Stefan, I sent it to you by mail. Message "test" delivered successfully, "test2" - failed.
Comment 3 Artur Cuvasov 2013-11-18 06:22:25 EST
---> Package pidgin-sipe.i686 0:1.17.0-1.fc20 will be updated
---> Package pidgin-sipe.i686 0:1.17.1-1.fc20 will be an update
Comment 4 Stefan Becker 2013-11-18 06:34:23 EST
The server complains about

  SIP/2.0 500 Stale CSeq Value
  ...
  CSeq: 4 MESSAGE
  Ms-client-diagnostics: 52136;reason="The request sequence number is corrupted"

The only difference from 1.17.0 is that now your client sends out a typing "reset" indication after the MESSAGE, i.e.

  -> MESSAGE (4)
  -> INFO (5)
  <- 200 OK (5)
  <- 500 (4)

I'm guessing if you fetch 1.17.1 and one line to src/core/sipe-user.c:

------------------------------
void sipe_core_user_feedback_typing(struct sipe_core_public *sipe_public,
...
        struct sip_dialog *dialog = sipe_dialog_find(session, to);

-->     if (!typing) return;
-------------------------------

that it works for you again?
Comment 5 Artur Cuvasov 2013-11-18 06:40:59 EST
I disabled "Notify buddies if you are typing to them" option in preferences, looks better now.
Comment 6 Stefan Becker 2013-11-18 06:49:57 EST
Thanks. This looks again like one of those cases where SIPE would need a complete rewrite from scratch for the SIP message handling :-(

I have an idea for a workaround at least for the libpurple backend which I will submit to git HEAD.
Comment 7 Fedora Update System 2013-11-30 11:54:26 EST
pidgin-sipe-1.17.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.2-1.fc20
Comment 8 Fedora Update System 2013-11-30 11:55:35 EST
pidgin-sipe-1.17.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.2-1.fc19
Comment 9 Fedora Update System 2013-11-30 11:56:20 EST
pidgin-sipe-1.17.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.2-1.fc18
Comment 10 Fedora Update System 2013-11-30 11:58:11 EST
pidgin-sipe-1.17.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.2-1.el6
Comment 11 Fedora Update System 2013-11-30 11:58:58 EST
pidgin-sipe-1.17.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.2-1.el5
Comment 12 Fedora Update System 2013-11-30 21:48:19 EST
Package pidgin-sipe-1.17.2-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing pidgin-sipe-1.17.2-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12231/pidgin-sipe-1.17.2-1.el6
then log in and leave karma (feedback).
Comment 13 Stefan Becker 2013-12-01 12:03:50 EST
F20 variant of the 1.17.2 package has been pushed to updates-testing. Please update and verify that the problem is fixed for you. Thanks.
Comment 14 Fedora Update System 2013-12-11 15:18:32 EST
pidgin-sipe-1.17.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.3-1.fc20
Comment 15 Fedora Update System 2013-12-11 15:19:42 EST
pidgin-sipe-1.17.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.3-1.fc19
Comment 16 Fedora Update System 2013-12-11 15:20:28 EST
pidgin-sipe-1.17.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.3-1.fc18
Comment 17 Fedora Update System 2013-12-11 15:22:08 EST
pidgin-sipe-1.17.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.3-1.el6
Comment 18 Fedora Update System 2013-12-11 15:22:55 EST
pidgin-sipe-1.17.3-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.17.3-1.el5
Comment 19 Fedora Update System 2013-12-20 21:20:43 EST
pidgin-sipe-1.17.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-12-20 21:22:35 EST
pidgin-sipe-1.17.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2013-12-20 21:26:03 EST
pidgin-sipe-1.17.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2013-12-29 14:02:15 EST
pidgin-sipe-1.17.3-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2013-12-29 14:02:36 EST
pidgin-sipe-1.17.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.