Bug 1031555 - Account info should be shown at right corner on 404 page
Account info should be shown at right corner on 404 page
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Website (Show other bugs)
2.2.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: chris alfonso
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 04:45 EST by Tian Feng
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-31 15:18:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screeshot (33.02 KB, image/png)
2013-11-18 04:45 EST, Tian Feng
no flags Details

  None (edit)
Description Tian Feng 2013-11-18 04:45:56 EST
Created attachment 825445 [details]
screeshot

Description of problem:
Sign in web console and then go to a page which doesn't exist, check 404 page. The account info should be shown at right corner on 404 page. Detail can be found in attachment.

Version-Release number of selected component (if applicable):
2.0/2013-11-15.1

How reproducible:
Always

Steps to Reproduce:
1. Go to web console and access 404 page
2. Check account info at right corner on 404 page
3. 

Actual results:
No account info at right corner on 404 page

Expected results:
Account info should be shown at right corner on 404 page

Additional info:
Comment 2 chris alfonso 2014-01-31 15:18:52 EST
After looking into this issue and consulting the online developers it clear to me now that we can't fix this for page not found errors. OpenShift has 3 types of not found errors, and it's only the page not found error that isn't handled within the application. The reason this can't be done is because in order to add account information to a page not found error, the console application would have to service every url request under /console and that becomes a performance implication. For this reason openshift online has also elected to not show account login information in the top right of the screen, it uses a statically configured 404.html page.

Note You need to log in before you can comment on or make changes to this bug.