Bug 1031567 - [abrt] mate-image-viewer-1.6.1-2.fc19: gray_find_cell: Process /usr/bin/eom was killed by signal 6 (SIGABRT)
[abrt] mate-image-viewer-1.6.1-2.fc19: gray_find_cell: Process /usr/bin/eom w...
Status: CLOSED DUPLICATE of bug 678397
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:a32169c33f0c3f5520efc70c54c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 05:12 EST by glad08
Modified: 2013-11-18 07:27 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 07:27:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (131.67 KB, text/plain)
2013-11-18 05:12 EST, glad08
no flags Details
File: cgroup (141 bytes, text/plain)
2013-11-18 05:12 EST, glad08
no flags Details
File: core_backtrace (48.66 KB, text/plain)
2013-11-18 05:13 EST, glad08
no flags Details
File: dso_list (7.88 KB, text/plain)
2013-11-18 05:13 EST, glad08
no flags Details
File: environ (1.51 KB, text/plain)
2013-11-18 05:13 EST, glad08
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-18 05:13 EST, glad08
no flags Details
File: maps (43.56 KB, text/plain)
2013-11-18 05:13 EST, glad08
no flags Details
File: open_fds (1.03 KB, text/plain)
2013-11-18 05:13 EST, glad08
no flags Details
File: proc_pid_status (929 bytes, text/plain)
2013-11-18 05:13 EST, glad08
no flags Details
File: var_log_messages (642 bytes, text/plain)
2013-11-18 05:13 EST, glad08
no flags Details
testcase svg image (116.93 KB, image/svg+xml)
2013-11-18 05:15 EST, glad08
no flags Details

  None (edit)
Description glad08 2013-11-18 05:12:44 EST
Description of problem:
I do not know whether this matters, but this was so:
I ran dolphin from kate's open file dialog using context menu item "Open in file manager" on svg image file.
Than I open image in dolphin by clicking on it.
It rans in gimp, this was not that what I want, so I opens svg file properties and on "General" tab set default viewer for svg as eom mate image viewer.
After that I try to open svg again, and did it from second or third attempt.
One of two or three attempts of opening this svg led to the crash of eom.
Moreover, 3 of 4 crash dumps was unusable as gnome-abrt tool reported to me, and only 4-th I able to send.

Version-Release number of selected component:
mate-image-viewer-1.6.1-2.fc19

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        /usr/bin/eom /home/titov/git/core/models.svg
crash_function: gray_find_cell
executable:     /usr/bin/eom
kernel:         3.11.8-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 gray_find_cell at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:491
 #7 gray_record_cell at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:511
 #8 gray_set_cell at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:554
 #9 gray_render_scanline at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:659
 #10 gray_render_line at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:811
 #11 gray_render_conic at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:946
 #12 gray_conic_to at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:1157
 #13 FT_Outline_Decompose at /usr/src/debug/freetype-2.4.11/src/base/ftoutln.c:190
 #14 gray_convert_glyph_inner at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:1736
 #15 gray_convert_glyph at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:1838
Comment 1 glad08 2013-11-18 05:12:54 EST
Created attachment 825469 [details]
File: backtrace
Comment 2 glad08 2013-11-18 05:12:58 EST
Created attachment 825470 [details]
File: cgroup
Comment 3 glad08 2013-11-18 05:13:02 EST
Created attachment 825471 [details]
File: core_backtrace
Comment 4 glad08 2013-11-18 05:13:05 EST
Created attachment 825472 [details]
File: dso_list
Comment 5 glad08 2013-11-18 05:13:09 EST
Created attachment 825473 [details]
File: environ
Comment 6 glad08 2013-11-18 05:13:12 EST
Created attachment 825474 [details]
File: limits
Comment 7 glad08 2013-11-18 05:13:16 EST
Created attachment 825475 [details]
File: maps
Comment 8 glad08 2013-11-18 05:13:20 EST
Created attachment 825476 [details]
File: open_fds
Comment 9 glad08 2013-11-18 05:13:26 EST
Created attachment 825477 [details]
File: proc_pid_status
Comment 10 glad08 2013-11-18 05:13:30 EST
Created attachment 825478 [details]
File: var_log_messages
Comment 11 glad08 2013-11-18 05:15:23 EST
Created attachment 825490 [details]
testcase svg image

this image was generated from dot graph using graphviz dot -Tsvg
Comment 12 glad08 2013-11-18 05:16:51 EST
See description of problem in bug description and also there are attached svg, on which I got crash.
Comment 13 Marek Kašík 2013-11-18 07:27:49 EST

*** This bug has been marked as a duplicate of bug 678397 ***

Note You need to log in before you can comment on or make changes to this bug.