Bug 1031580 - [dbscripts] backup.sh/restore.sh do not work by default
[dbscripts] backup.sh/restore.sh do not work by default
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 05:41 EST by Jiri Belka
Modified: 2013-11-18 08:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 08:31:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2013-11-18 05:41:58 EST
Description of problem:
backup.sh and restore.sh do not work by default (default pg_hba.conf) at all. It is neither intuitive how to solve it nor it is clever to ask me for password.

(Enterprise means being dumb and user friendly by default.)

Customer does not need to be PSQL expert to just execute backup, would he know about PGPASSWORD? But even with PGPASSWORD it does not work for me.

# egrep -v "^#|^[ \t]*$" /var/lib/pgsql/data/pg_hba.conf
local   all         all                               ident
host    engine          engine          0.0.0.0/0               md5
host    engine          engine          ::0/0                   md5
host    all         all         127.0.0.1/32          ident
host    all         all         ::1/128               ident

# export PGPASSWORD=123456
# ./backup.sh -d engine -u engine -v -l /root/ -f backup-`date "+%Y%m%d%H%M"`.sql
Backup of database engine to /root//backup-201311181132.sql started...
pg_dump: [archiver (db)] connection to database "engine" failed: FATAL:  password authentication failed for user "engine"
pg_dump: *** aborted because of error
Backup of database engine failed.

Some more complains:
https://bugzilla.redhat.com/show_bug.cgi?id=976337#c10

Version-Release number of selected component (if applicable):
is23

How reproducible:
100%

Steps to Reproduce:
1. yum install rhevm
2. engine-setup
3. execute ./backup.sh (as above)

Actual results:
impossible

Expected results:
should be clever enough to guide me how to use it or it should ask me for password

Additional info:
using backup.sh and restore.sh should work without any hidden kung-fu. if one would need to change config, type undocumented (in -h output sense) environment variable, then this user could use non-paid upstream as enterprise friendliness of paid product is disputable.
Comment 1 Jiri Belka 2013-11-18 08:31:24 EST
> But even with PGPASSWORD it does not work for me.

14:25 < alonbl>             self.environment[$
14:25 < alonbl>                 osetupcons.DBEnv.PASSWORD$
14:25 < alonbl>             ] = self._generatePassword()$

Password is random...

Note You need to log in before you can comment on or make changes to this bug.