Bug 1031585 - [RHSC] Unable to remove more than one pair of bricks from a distributed-replicate ( 3x2 ) volume
[RHSC] Unable to remove more than one pair of bricks from a distributed-repli...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 2.1.2
Assigned To: anmol babu
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 05:53 EST by Shruti Sampat
Modified: 2015-05-13 12:26 EDT (History)
9 users (show)

See Also:
Fixed In Version: cb11
Doc Type: Enhancement
Doc Text:
Enhancements have been made to allow the removal of more than a pair of bricks from a distributed-replicate volume.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 03:04:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (170.41 KB, image/png)
2013-11-18 05:53 EST, Shruti Sampat
no flags Details
engine logs (1.58 MB, text/x-log)
2013-11-18 05:57 EST, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22229 None None None Never

  None (edit)
Description Shruti Sampat 2013-11-18 05:53:41 EST
Created attachment 825525 [details]
screenshot

Description of problem:
-----------------------

On trying to remove more than one pair of bricks from a distributed-replicate ( 3x2 ) volume the following error was seen - 

Incorrect bricks selected for removal in Distributed Replicate volume. <br/> Either all the selected bricks should be from the same sub volume or one brick each for every sub volume!
- 10.70.37.96:/rhs/brick3/b1
- 10.70.37.77:/rhs/brick4/b1
- 10.70.37.96:/rhs/brick4/b1
- 10.70.37.77:/rhs/brick3/b1

The same operation was successful from gluster CLI - 

[root@rhs tmp]# gluster v remove-brick dis_rep_vol 10.70.37.77:/rhs/brick3/b1 10.70.37.96:/rhs/brick3/b1  10.70.37.77:/rhs/brick4/b1 10.70.37.96:/rhs/brick4/b1 start
volume remove-brick start: success
ID: 3f65cf69-27d5-47c1-b464-9bcf61d23916

The operation should have succeeded from the Console too.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.23.master.el6_5 

How reproducible:
Always

Steps to Reproduce:
1. Create a distributed-replicate ( 3x2 ) volume, start it.
2. Select two pairs of bricks from the Console and click on Remove.

Actual results:
The above described error message is seen.

Expected results:
The operation should succeed.

Additional info:
Comment 1 Shruti Sampat 2013-11-18 05:57:16 EST
Created attachment 825526 [details]
engine logs
Comment 3 Shruti Sampat 2013-12-12 06:25:48 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.27.beta.el6_5. Removing multiple replica groups at once is now possible.
Comment 4 Shalaka 2014-01-06 00:04:35 EST
Please review and signoff the edited DocText.
Comment 5 anmol babu 2014-01-06 00:44:44 EST
yep concise and appropriate.
Comment 6 Dusmant 2014-01-06 02:18:25 EST
Anmol, change the doc_type to enhancement and add the notes. 
It's a change in behaviour and hence an enhancement.
Comment 7 Shalaka 2014-01-06 23:59:53 EST
Please review the edited DocText and confirm.
Comment 8 anmol babu 2014-01-07 01:06:51 EST
yep looks good to me.
Comment 10 errata-xmlrpc 2014-02-25 03:04:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.