Bug 1031621 - Freecol hangs after video
Summary: Freecol hangs after video
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecol
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-18 12:05 UTC by Ankur Sinha (FranciscoD)
Modified: 2013-11-27 04:39 UTC (History)
2 users (show)

Fixed In Version: freecol-0.10.7-3.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-19 21:45:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Ankur Sinha (FranciscoD) 2013-11-18 12:05:08 UTC
Description of problem:
I started freecol for the first time, the video comes up but it hangs after that. I'm using Gnome3. 

Version-Release number of selected component (if applicable):
freecol-0.10.7-2.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install freecol on Fedora 20
2. Try running it in Gnome3
3.

Actual results:
Stops and hangs after video.

Expected results:
Should finish video and continue to main menu.

Additional info:
I found another bug where you'd requested the user to use gnome fallback mode. Now that Gnome doesn't ship it anymore, I'll try it with another desktop environment on my other machine tomorrow and report if it works. 

Command line output:
[asinha@ankur-laptop  ~]$ freecol
/usr/bin/build-classpath: Could not find vorbisspi Java extension for this JVM
/usr/bin/build-classpath: Could not find tritonus Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Java virtual machine used: /usr/lib/jvm/jre-openjdk/bin/java
classpath used: /usr/share/java/freecol.jar:/usr/share/java/commons-cli.jar:/usr/share/java/cortado.jar:/usr/share/java/jogg.jar:/usr/share/java/jorbis.jar:/usr/share/java/miglayout.jar
main class used: net.sf.freecol.FreeCol
flags used:
options used: -Xmx512M -Xincgc -Dsun.java2d.pmoffscreen=false
arguments used: --freecol-data /usr/share/freecol/data
[INFO] init()
[INFO] param "url" has string value "file:/usr/share/freecol/data/rules/classic/resources/video/freecol-opening.video.ogg"
[INFO] param "seekable" has enum value "0" (auto)
[INFO] param "live" has enum value "0" (auto)
[INFO] param "duration" has double value "-1.0"
[INFO] param "audio" has boolean value "true"
[INFO] param "video" has boolean value "true"
[INFO] param "kateIndex" has int value "0"
[INFO] param "kateLanguage" has string value ""
[INFO] param "kateCategory" has string value ""
[INFO] param "statusHeight" has int value "12"
[INFO] param "autoPlay" has boolean value "true"
[INFO] param "showStatus" has enum value "2" (hide)
[INFO] param "hideTimeout" has int value "3"
[INFO] param "showSpeaker" has boolean value "true"
[INFO] param "showSubtitles" has boolean value "true"
[INFO] param "keepAspect" has boolean value "true"
[INFO] param "ignoreAspect" has boolean value "false"
[INFO] param "bufferSize" has int value "200"
[INFO] param "bufferLow" has int value "10"
[INFO] param "bufferHigh" has int value "70"
[INFO] param "debug" has int value "0"
[INFO] param "userId" has string value "null"
[INFO] param "password" has string value "null"



^C[asinha@ankur-laptop  ~]$ rpm -q freecol
freecol-0.10.7-2.fc20.noarch
[asinha@ankur-laptop  ~]$

Comment 1 Hans de Goede 2013-11-18 13:02:45 UTC
Thanks for the bug-report this seems to be fixed by this upstream commit:
https://sourceforge.net/p/freecol/git/ci/6c0fb53d12447f6c14ce75d8eb9edcf08402c2d0/

I'm going to do a build with this commit added, and if it fixes things I'll push it as an update.

Comment 2 Fedora Update System 2013-11-18 13:44:04 UTC
freecol-0.10.7-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/freecol-0.10.7-3.fc20

Comment 3 Fedora Update System 2013-11-18 13:49:31 UTC
freecol-0.10.7-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/freecol-0.10.7-3.fc18

Comment 4 Fedora Update System 2013-11-18 14:02:17 UTC
freecol-0.10.7-3.fc19.1 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/freecol-0.10.7-3.fc19.1

Comment 5 Fedora Update System 2013-11-18 20:18:08 UTC
Package freecol-0.10.7-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freecol-0.10.7-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21613/freecol-0.10.7-3.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-11-19 21:45:57 UTC
freecol-0.10.7-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2013-11-27 04:30:52 UTC
freecol-0.10.7-3.fc19.1 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2013-11-27 04:39:45 UTC
freecol-0.10.7-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.