This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1031640 - Gluster does not shut down w/ systemd
Gluster does not shut down w/ systemd
Status: CLOSED DUPLICATE of bug 1022542
Product: Fedora
Classification: Fedora
Component: glusterfs (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kaleb KEITHLEY
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 08:00 EST by Bert DeKnuydt
Modified: 2013-11-18 08:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 08:04:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bert DeKnuydt 2013-11-18 08:00:21 EST
Description of problem:

Systemd command to stop gluster{d,fsd} does not work properly

Version-Release number of selected component (if applicable):

glusterfs-3.4.1-1.fc19.x86_64

How reproducible:

Always.

Steps to Reproduce:
0. Have a functional gluster environment.
1. As root: systemctl stop glusterd glusterfsd
   Give it some time to figure out.
2. As root: systemctl status glusterd glusterfsd
   See that it reports stopped.
3. As root: ps -ef|grep gluster
   See that the gluster stuff is still running. And
   even functional.

Actual results:

See above.

Expected results:

Nothing gluster alive anymore.

Additional info:

To unmount underlying fs, for example, explicit killing of the daemon's
is needed.
Comment 1 Niels de Vos 2013-11-18 08:04:27 EST
(In reply to Bert DeKnuydt from comment #0)
> Expected results:
> 
> Nothing gluster alive anymore.

glusterd and glusterfsd should not stop the fuse-mounts. The mountpoint may well keep functioning even if there is no local glusterd/glusterfsd.

I think this is a duplicate of 1022542, please comment on that bug, it's proposed solution and give karma on the test-packages.

Thanks!

*** This bug has been marked as a duplicate of bug 1022542 ***

Note You need to log in before you can comment on or make changes to this bug.