Bug 1031642 - WebServices subsystem attribute modify-wsdl-address false value ignored
WebServices subsystem attribute modify-wsdl-address false value ignored
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: DR0
: EAP 6.3.0
Assigned To: Alessio Soldano
Rostislav Svoboda
Russell Dickenson
:
Depends On: 1061340
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 08:03 EST by Petr Sakař
Modified: 2014-06-28 11:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previous versions of JBoss EAP 6 carried a bug that prevented the WS stack from processing @WebService(wsdlLocation=...) when performing wsdl soap:address rewrite. The annotation attribute above was not processed when the annotation was put on service endpoint interfaces only. This issue has been corrected in this release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:42:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deployed war (5.01 KB, application/x-webarchive)
2013-11-18 08:03 EST, Petr Sakař
no flags Details

  None (edit)
Description Petr Sakař 2013-11-18 08:03:50 EST
Created attachment 825590 [details]
deployed war

Description of problem:

WSDL address in provided wsdl is modified even when attribute modify-wsdl-address of web services subsystem is set to false 

Version-Release number of selected component (if applicable):
EAP 6.2.0.ER7, 6.2.0.CR1, 6.2.0.CR2 

How reproducible:
always

Steps to Reproduce:
1. start AS
   bin/standalone.sh
2. change configuration
   bin/jboss-cli.sh -c "/subsystem=webservices/:write-attribute(name=modify-wsdl-address,value=false)"
3. reload AS
   bin/jboss-cli.sh -c "reload"
4. verify attribute value
   bin/jboss-cli.sh -c "/subsystem=webservices/:read-attribute(name=modify-wsdl-address)"
5. deploy war
   bin/jboss-cli.sh -c "deploy /tmp/CLIWebservicesModifyWsdlAddressTestCase.war" 
6. Check provided wsdl on address 
   http://localhost:8080/CLIWebservicesModifyWsdlAddressTestCase/AnnotatedSecurityService?wsdl


Actual results:
WSDL contains modified SOAP address
<soap:address location="http://localhost:8080/CLIWebservicesModifyWsdlAddressTestCase/AnnotatedSecurityService"/>

Expected results:
WSDL should contain unmodified SOAP address from deployed war from file META-INF/endpoint.wsdl
<soap:address location="http://localhost:8081/CLIWebservicesModifyWsdlAddressTestCase/AnnotatedSecurityService"/>



Additional info:
Comment 1 Alessio Soldano 2013-11-18 08:13:56 EST
The wsdl file contained in the deployment is not actually used for the org.jboss.test.ws.cli.AnnotatedServiceImpl endpoint.
Comment 2 Rostislav Svoboda 2013-11-18 09:29:18 EST
reproducer: https://github.com/psakar/eap-ws-management-tests
Comment 3 Alessio Soldano 2013-11-18 10:54:28 EST
As said on IRC, please disregard my former comment (#1) as it's based on wrong decompiled archive.
Comment 4 Alessio Soldano 2013-11-18 13:11:38 EST
This is caused by the bug here: https://issues.jboss.org/browse/JBWS-3736
Comment 5 Alessio Soldano 2013-11-18 13:13:06 EST
A workaround should be to simply move the wsdlLocation attribute from the @WebService annotation in the SEI to the one in the endpoint implementation.
Comment 6 Rostislav Svoboda 2013-11-19 02:47:27 EST
Lowering severity, we have workaround.
Comment 8 favrycio 2014-04-03 10:19:05 EDT
This bug persist on wildfly
Comment 9 Alessio Soldano 2014-04-03 10:46:16 EDT
favrycio, this has been fixed in https://issues.jboss.org/browse/JBWS-3736 , which is also included in JBossWS 4.2.4, which in turn will be in WildFly 8.0.1.
Comment 10 Kabir Khan 2014-04-04 10:55:16 EDT
Setting to ON_QA since upgrade should fix this
Comment 11 Petr Sakař 2014-04-08 06:45:13 EDT
Verified for EAP-6.3.0.ER1

Note You need to log in before you can comment on or make changes to this bug.