This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1031646 - Unable to start EAP 5 server via JON after being stopped via JON on Windows, Oracle JDK 1.6
Unable to start EAP 5 server via JON after being stopped via JON on Windows, ...
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 5 (Show other bugs)
JON 3.2
Unspecified Windows
urgent Severity urgent
: ---
: JON 3.3.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 1119503
  Show dependency treegraph
 
Reported: 2013-11-18 08:05 EST by Radim Hatlapatka
Modified: 2014-10-16 21:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1119503 (view as bug list)
Environment:
Last Closed: 2014-09-11 09:18:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error when starting EAP5 back again (55.95 KB, application/zip)
2013-11-18 08:05 EST, Radim Hatlapatka
no flags Details

  None (edit)
Description Radim Hatlapatka 2013-11-18 08:05:55 EST
Created attachment 825602 [details]
error when starting EAP5 back again

Description of problem:
When I stop EAP 5 server on Windows with Oracle JDK 1.6 (1.6.0.45) and I am trying to start it again it fails with java.net.SocketException: Unrecognized Windows Sockets error: 10106
- for details see attached EAP 5 server logs


Version-Release number of selected component (if applicable):
EAP 5.2.0 vs JON 3.2.0.ER5


How reproducible:
always 

Steps to Reproduce:
1. start EAP 5 on Windows using Oracle JDK 1.6.0.45 (run.bat -c default -b localhost)
2. import the server to JON
3. shutdown the EAP5 server and then start it back (both via JON)

Actual results:
start operation fails


Expected results:
start operation succeeds


Additional info:
With Oracle JDK 1.7.0 it works just fine


After uninventoring the server you can see in autodiscovery queue rediscovered server even though it is not running and it didn't recognized the management port resulting that the EAP server name doesn't contain port => EAP localhost default
Comment 1 Mike Foley 2013-11-18 11:34:34 EST
I am going to refer this BZ to the JON Triage Team (yarboro, heiko, larry, alan, foley) for Triage.  as a result of this meeting, the JON Triage team will determine if this is blocking for JON 3.2 GA.

Adding "Needs Info" for myarboro to schedule this BZ for triage
Comment 2 Larry O'Leary 2013-11-18 12:02:27 EST
@Radim can you confirm that this is a regression from 3.1.2?
Comment 3 Radim Hatlapatka 2013-11-19 08:58:52 EST
I have checked this with JON 3.1.2 and the issue is also there.
Comment 12 Larry O'Leary 2014-02-13 20:54:37 EST
Re-targeted to CP02 to reduce CP01 overall payload.
Comment 14 Jay Shaughnessy 2014-08-29 16:02:07 EDT
Are you using a 32-Bit 1.6 JDK?  Versions prior to 3.3 required the 32-Bit 1.6 JDK (not JRE).

Another possibility is something I found doing some research.  I saw that Jboss EAP startup failed, with this error, on some Windows systems that have the IPv6 TCP Stack installed. "If both IPv4 and IPv6 are installed on the computer, the Java Virtual Machine (JVM) may have problems closing or opening sockets at the operating system level."

Try adding:

 -Djava.net.preferIPv4Stack=true
Comment 16 Radim Hatlapatka 2014-09-11 08:52:08 EDT
I have figured out that it is caused by exceeding limitation of command line length caused by environment variables.

For details about the limitation you can look at https://mojo.redhat.com/docs/DOC-977787
Comment 17 Radim Hatlapatka 2014-09-11 09:18:34 EDT
Due that limitation some part of env variables could exceed the limit and cause some parts to be missing, in this case it could be the -Djava.net.preferIPv4Stack=true which is in standard part of JAVA_OPTS when starting EAP 5 (part of run.bat script).

Thereby this is actually not a bug and closing it as such.

Note You need to log in before you can comment on or make changes to this bug.