Bug 1031650 - openlmi-providers: thread safety issues
openlmi-providers: thread safety issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openlmi-providers (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Minar
Robin Hack
:
Depends On:
Blocks: 1031135
  Show dependency treegraph
 
Reported: 2013-11-18 08:14 EST by Florian Weimer
Modified: 2014-06-17 23:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: openlmi-providers-0.4.2-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:25:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-11-18 08:14:47 EST
The function src/fan/fan.c:sprintf_chip_name() is not thread-safe.

The locking in src/logicalfile/LMI_UnixFileProvider.c:get_selabel_handle() is ineffective because it does not cover the actual use of the pointer.  The mutex must be held by the caller, as long as the pointer is used.
Comment 6 Ludek Smid 2014-06-13 05:25:26 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.