Bug 1031656 - REST RollUps from 5.2.4 to 6.0.0 -- migrates 0 entries (probably due to PersistenceException)
REST RollUps from 5.2.4 to 6.0.0 -- migrates 0 entries (probably due to Persi...
Status: CLOSED WONTFIX
Product: JBoss Data Grid 6
Classification: JBoss
Component: Server (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 08:22 EST by Tomas Sykora
Modified: 2013-12-23 02:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-23 02:36:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3723 Major Closed REST RollUps from 5.2.4 to 6.0.0 -- migrates 0 entries (probably due to PersistenceException) 2014-03-12 06:06:01 EDT

  None (edit)
Description Tomas Sykora 2013-11-18 08:22:17 EST
See linked JIRA
Comment 2 JBoss JIRA Server 2013-11-18 08:31:44 EST
Tomas Sykora <tsykora@redhat.com> made a comment on jira ISPN-3723

might be connected to: https://issues.jboss.org/browse/ISPN-3724
Comment 3 JBoss JIRA Server 2013-11-18 08:32:35 EST
Tomas Sykora <tsykora@redhat.com> made a comment on jira ISPN-3723

Attached server output file
Comment 4 Tristan Tarrant 2013-11-25 05:42:18 EST
In order for REST upgrades to work, we need specific support on the "source" which doesn't exist in JDG 6.1.x.
The solutions are: 
- we explicitly say that we cannot perform rolling upgrades for REST from 6.1 to 6.2
- we (heavily) patch the JDG 6.1.x REST endpoint to add support and release a compatibility patch.
Comment 5 Martin Gencur 2013-12-10 05:17:53 EST
Looks like this issues should be closed. IMO, REST roll-ups are supposed to work from JDG 6.2 to newer versions. Removing this from JDG 6.2 blockers list.
Comment 6 JBoss JIRA Server 2013-12-23 02:36:34 EST
Tristan Tarrant <ttarrant@redhat.com> updated the status of jira ISPN-3723 to Closed

Note You need to log in before you can comment on or make changes to this bug.