Bug 1031686 - oo-diagnostics should call oo-admin-yum-validator
oo-diagnostics should call oo-admin-yum-validator
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 09:41 EST by Brenton Leanhardt
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version: rubygem-openshift-origin-common-1.17.2.1-2.el6op
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 11:20:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-11-18 09:41:29 EST
Description of problem:

Now that we're planning to ship oo-admin-yum-validator via RPM it would be useful to have oo-diagnostics call it.  I do not think we should automatically fix anything but install use the --report-all flag.
Comment 5 Luke Meyer 2013-11-19 18:34:06 EST
origin-server: https://github.com/openshift/origin-server/pull/4203

enterprise-server:
commit d45576b972fd5ef2cc704db84f65f4191ca57261
Author: Luke Meyer <lmeyer@redhat.com>
Date:   Tue Nov 19 18:26:47 2013 -0500

    <oo-diagnostics> validate yum conf if possible - bug 1031686


NOTE: this test will fail miserably under OSE 2.0 beta until we can actually ship in the 2.0 GA channels, because the beta channels are different.
Comment 6 openshift-github-bot 2013-11-19 19:55:56 EST
Commits pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/d7c930be14d2c11df5072e439dbc7029b2d9cf61
<oo-diagnostics> test for clashing app frontends, bug 1031686

https://github.com/openshift/origin-server/commit/6379455911c5592548adeeb68e524ff13db62f42
<oo-diagnostics> validate yum conf if possible - bug 1031686
Comment 9 Ma xiaoqiang 2013-11-25 05:00:25 EST
check on puddle[2.0/2013-11-22.1]
#oo-diagnostics test_yum_configuration 
WARN: test_yum_configuration
        oo-admin-yum-validator reported some possible problems
        with your package source configuration:
--------------------------------------------------------------
      No roles have been specified. Attempting to guess the roles for this system...
If the roles listed below are incorrect or incomplete, please re-run this script with the appropriate --role arguments
    broker
    client
Detected OpenShift Enterprise repository subscription managed by Red Hat Subscription Manager.
Could not determine product version. Please re-run this script with the --oo-version argument.
Please re-run this tool after making any recommended repairs to this system

--------------------------------------------------------------
        Incorrect package source configuration could lead to
        failure to install the correct RPMs.

1 WARNINGS
NO ERRORS

Now it can call oo-admin-yum-validator, but it can't find the right version of openshift. it should run with the "-c beta2.ini" flag.
Comment 10 Luke Meyer 2013-11-25 09:46:35 EST
We can't ship it with -c beta.ini because once it ships... it will no longer be the beta. Because the beta channels are different from the GA channels, we effectively cannot test this until the GA channels are populated.

Ideally in the future yum-validator would be able to detect the OSE version is beta and use that. Right now it can't.

Not sure what state to leave this bug in. Would like to test it as soon as GA channels have content.
Comment 11 Ma xiaoqiang 2013-12-15 20:43:28 EST
check it on puddle[2.0/2013-12-09.3] and rhn-2.0
# oo-diagnostics 
<--snip-->
WARN: test_yum_configuration
        oo-admin-yum-validator reported some possible problems
        with your package source configuration:
--------------------------------------------------------------
      No roles have been specified. Attempting to guess the roles for this system...
If the roles listed below are incorrect or incomplete, please re-run this script with the appropriate --role arguments
    node
    node-eap
Detected OpenShift Enterprise repository subscription managed by RHN Classic or RHN Satellite.
Detected installed OpenShift Enterprise version 2.0

The required OpenShift Enterprise repositories are missing:
    rhel-x86_64-server-6-ose-2.0-jbosseap
    jbappplatform-6-x86_64-server-6-rpm
Please verify that an OpenShift Enterprise subscription is attached to this system using either RHN Classic or Red Hat Subscription Manager by following the instructions here: https://access.redhat.com/site/articles/522923
Checking if yum-plugin-priorities is installed
Checking channel/repository priorities
Please re-run this tool after making any recommended repairs to this system
<--snip-->

Now oo-diagnostics have called oo-admin-yum-validator to check the resource.

Note You need to log in before you can comment on or make changes to this bug.