Bug 1031708 - Dependency issue
Dependency issue
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-aws-sdk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joseph Marrero
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 10:17 EST by Remi Collet
Modified: 2013-12-13 21:48 EST (History)
2 users (show)

See Also:
Fixed In Version: php-aws-sdk-2.4.10-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-01 04:32:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2013-11-18 10:17:36 EST
Can you please check the dependencies of this package ?

From package.xml
 <dependencies>
  <required>
   <php>
    <min>5.3.3</min>
   </php>
   <pearinstaller>
    <min>1.4.0</min>
   </pearinstaller>
   <package>
    <name>Guzzle</name>
    <channel>guzzlephp.org/pear</channel>
    <min>3.0.3</min>
   </package>
   <extension>
    <name>curl</name>
   </extension>
  </required>
 </dependencies>

So php-pear(guzzlephp.org/pear/Guzzle) >= 3.0.3

New version 2.4.10 is released.

From composer.json
    "require": {
        "php": ">=5.3.3",
        "guzzle/guzzle": "~3.7.0"
    },

So 
php-pear(guzzlephp.org/pear/Guzzle) >= 3.7.0
php-pear(guzzlephp.org/pear/Guzzle) <  3.8

And    "suggest": {
        "doctrine/cache": "Adds support for caching of credentials and responses",
        "ext-apc": "Allows service description opcode caching, request and response caching, and credentials caching",
        "ext-openssl": "Allows working with CloudFront private distributions and verifying received SNS messages",
        "monolog/monolog": "Adds support for logging HTTP requests and responses",
        "symfony/yaml": "Eases the ability to write manifests for creating jobs in AWS Import/Export"
   }

So php-Monolog and php-symfony2-Yaml (v2), but no need of php-symfony2-YAML (v1)
Comment 1 Fedora Update System 2013-11-18 20:51:57 EST
php-aws-sdk-2.4.10-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/php-aws-sdk-2.4.10-1.fc19
Comment 2 Fedora Update System 2013-11-18 20:52:10 EST
php-aws-sdk-2.4.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/php-aws-sdk-2.4.10-1.fc20
Comment 3 Fedora Update System 2013-11-18 20:52:19 EST
php-aws-sdk-2.4.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/php-aws-sdk-2.4.10-1.fc18
Comment 4 Fedora Update System 2013-11-19 16:49:29 EST
Package php-aws-sdk-2.4.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-aws-sdk-2.4.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21711/php-aws-sdk-2.4.10-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-12-01 04:32:42 EST
php-aws-sdk-2.4.10-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-12-01 04:39:50 EST
php-aws-sdk-2.4.10-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-12-13 21:48:49 EST
php-aws-sdk-2.4.10-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.